1994 transmission problem - Corvette Forum : DigitalCorvettes.com Corvette Forums
 
 
Go Back   Corvette Forum : DigitalCorvettes.com Corvette Forums > C4 Corvette Forums > C4 Corvette
Register Forums Garage Garage Mark Forums Read Auto EscrowInsurance

Notices

C4 Corvette General | Technical | Performance | Aftermarket | Discussions

Other sections:
Corvettes Classifieds
Corvette Detailing & Car Care
Corvette Audio/Video/Radar
General Automotive/Shop/Tools
Corvette Performance Driving/Racing

Shops/Tuners
Custom Image Corvettes
A&A Corvette
Corvette tuner

Interior
Corvette aftermarket products

Insurance

Parts & Products
Race Ramps
Edelbrock
ATI/Procharger
Corvetteguys.com
Melrose Motorsports
Parts Taxi
Airaid
Mid America Motorworks
Pfadt Racing
Madvette Motorsports
Hi-tech Custom Concepts
Corvette aftermarket products
Corvette Garage
Corvette Parts and Accessories
Corvette Car Care Products
Corvette HID
Mid America Motoroworks

Tracks/Schools
Bob Bondurant School of High Performance Driving
Corvette driving school

Wheels/Tires
Cray Wheels

Services
BADWERKS.com
Reply
 
Thread Tools
Old 10-18-2009, 03:24 PM   #1
KingC6
DC Crew
 
KingC6's Avatar
 
Posts: 646
Member #46340
Member since: May 2006
Location: Cincinnati, Ohio

My Corvette(s)
1994 teal c4. 2011 shelby gt500

Thanks: 0
Thanked 0 Times in 0 Posts
1994 transmission problem

last night my 94 started having tranny problems. it shifts normal and fine, but no for some reason i have no reverse and neutral has become drive. its an automatic and when you put it in reverse it engages but doenst move and will only rev to 2k. then when you put it in neutral it will move forward like its in drive...any ideas??
KingC6 is offline   Reply w/quote Quick reply to this message
2009 GT 1 Z06
2008 Silver convertible
2004 Z06 Commerative Edition Z16
1994 Aqua coupe
1991 White coupe
Sponsored Links
Advertisement
 
Old 10-18-2009, 04:28 PM   #2
-=Jeff=-
El Teafive
 
-=Jeff=-'s Avatar
 
Posts: 10,468
Member #2
Member since: Jan 2003
Location: Bartlett, IL

My Corvette(s)
1990 ZR-1 #1051

Thanks: 0
Thanked 6 Times in 6 Posts
when you put the shifter in Park, is the trans actually in Park?

wondering if the linkage for the shifter is out of adjustment somehow
-=Jeff=- is online now   Reply w/quote Quick reply to this message
-=Jeff=-
1990 ZR-1 #1051
NCM Lifetime Member #978

Useful Links: C4 Tech info|C3 Tech Info|Adam's Polishes
Old 10-18-2009, 05:16 PM   #3
Pete K
DC Crew
 
Posts: 226
Member #66266
Member since: Oct 2007
Location: Nanticoke, Pa

My Corvette(s)
87 coupe

Thanks: 0
Thanked 0 Times in 0 Posts
Either the shift linkage (internal or external) is screwed up, or the forward clutch pack has overheated and warped the stels, resulting in a locked apply.
Pete K is offline   Reply w/quote Quick reply to this message
Old 10-18-2009, 05:42 PM   #4
Dipstick
DC Crew
 
Dipstick's Avatar
 
Posts: 89
Member #83325
Member since: Mar 2009
Location: Palm Coast, Fla/USA

My Corvette(s)
1993 6sp coupe / 1989 convertable automatic

Thanks: 0
Thanked 0 Times in 0 Posts
Years ago I had a old Mustang that did the same thing. The belville spring in the front clutch broke and wedged in the clutch pack and kept the forward clutch applied. Ther car was locked in a forward and reverse when the selector was put in reverse and would move forward when in neutral. Good luck with it. I hope it turns out to be something simple for you.
Dipstick is offline   Reply w/quote Quick reply to this message
You're thinkin' with yer dipstick, Jimmy!
Old 10-18-2009, 06:47 PM   #5
KingC6
DC Crew
 
KingC6's Avatar
 
Posts: 646
Member #46340
Member since: May 2006
Location: Cincinnati, Ohio

My Corvette(s)
1994 teal c4. 2011 shelby gt500

Thanks: 0
Thanked 0 Times in 0 Posts
yeah im hoping its something simple. oh well ill find out tommorow..thanks for the replies
KingC6 is offline   Reply w/quote Quick reply to this message
2009 GT 1 Z06
2008 Silver convertible
2004 Z06 Commerative Edition Z16
1994 Aqua coupe
1991 White coupe
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Corvette Forum : DigitalCorvettes.com Corvette Forums forums, you must first register.
Please enter your desired user name (12 CHARACTERS MAXIMUM), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Powered by vBadvanced CMPS v3.2.2

All times are GMT -6. The time now is 01:37 PM.




Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
2003-2011, DigitalCorvettes.com - All Rights Reserved