Popping sound front of car - Corvette Forum : DigitalCorvettes.com Corvette Forums
 
 
Go Back   Corvette Forum : DigitalCorvettes.com Corvette Forums > C5 Corvette Forums > C5 Corvette - General Discussion
Register Forums Garage Garage Mark Forums Read Auto EscrowInsurance

Notices

C5 Corvette - General Discussion General | Technical | Performance | Aftermarket | Discussions

Other sections:
Corvettes Classifieds
Corvette Detailing & Car Care
Corvette Audio/Video/Radar
General Automotive/Shop/Tools
Corvette Performance Driving/Racing

Shops/Tuners
Custom Image Corvettes
A&A Corvette
Corvette tuner

Interior
Corvette aftermarket products

Insurance

Parts & Products
Race Ramps
Edelbrock
ATI/Procharger
Corvetteguys.com
Melrose Motorsports
Parts Taxi
Airaid
Mid America Motorworks
Pfadt Racing
Madvette Motorsports
Hi-tech Custom Concepts
Corvette aftermarket products
Corvette Garage
Corvette Parts and Accessories
Corvette Car Care Products
Corvette HID
Mid America Motoroworks

Tracks/Schools
Bob Bondurant School of High Performance Driving
Corvette driving school

Wheels/Tires
Cray Wheels

Services
BADWERKS.com
Reply
 
Thread Tools
Old 01-22-2013, 08:34 PM   #1
Longhorn03
DC Crew
 
Longhorn03's Avatar
 
Posts: 94
Member #108034
Member since: Jun 2010
Location: Willis/Texas/USA

My Corvette(s)
c5 msg2003 Mods; Englandgreen Mayhem II

Thanks: 0
Thanked 0 Times in 0 Posts
Popping sound front of car

I have replaced end links and bushings on sway bar. Still making popping sounds. Seems like low speeds turning and incline/decline. Speed bumps straight no noise. Can bushings be to tight or need to be torqued.
Longhorn03 is offline   Reply w/quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 01-23-2013, 06:22 PM   #2
Choreo
DC Crew
 
Choreo's Avatar
 
Posts: 1,205
Member #56229
Member since: Jan 2007
Location: Midland, Texas

My Corvette(s)
2001 Coupe

Thanks: 10
Thanked 17 Times in 17 Posts
Quote:
Originally Posted by Longhorn03 View Post
I have replaced end links and bushings on sway bar. Still making popping sounds. Seems like low speeds turning and incline/decline. Speed bumps straight no noise. Can bushings be to tight or need to be torqued.
I may have the same problem. Soon after I installed Metal endlinks and C6-Z51 Sway Bars I started getting a rattle on all 4 corners of the car. I torqued everything to spec initially and no sounds, but after a few weeks it started rattling - mostly when turning into driveways at an angle - all four corners rattle. That has been on my list of things to double-check - maybe this weekend.
Choreo is online now   Reply w/quote Quick reply to this message
Old 01-23-2013, 11:14 PM   #3
DropTopGal
 
DropTopGal's Avatar
 
Posts: 393
Member #98067
Member since: Jan 2010
Location: Boca Raton, FL

My Corvette(s)
2010 GS Coupe ~ 2008 VY Vert

Thanks: 1
Thanked 106 Times in 63 Posts
When I/we had the PFADT JOC stage 1 installed, it seems that the front shocks made a popping sound every now and then. One time really scared me because it happened over an uneven road several times but only from the passenger front side when I was rather far from home in Miami.

One thing my hubby noticed, after a couple of weeks driving with the new shocks & sway thingies, the shocks seemed to settle some and the top of the shock where the black rubber ring and nut is, the metal bolt part of the shock was extended out more - about an inch.

The Vette seems to drive and handle just fine, so I presume this is common.
DropTopGal is offline   Reply w/quote Quick reply to this message
Good Girls ~~ Drive It HARD
**SOLD** 2010 Grand Sport JSB~3LT~A6~NPP~Chrome Wheels~Nav~Heritage~Titanium-Ebony~Full Rear Wing~Sport Pedals ~ Dyno: 445hp / 429tq @ wheels

Mods: LG Longtube Headers~LG X Pipe~LG High Flow Cats~3" Coltrs~160' Stat~PFADT JOC Stg I Suspension~PCM & A6 Tune
Cosmetic: RaceMesh Grills~LED Tail Lights~Mild to Wild~Lloyds Mats~Vette Tray2~JWM LED Lights~Custom LED~Corvette Inserts~Chrome Exhaust Plate~Venture Shield~18% Tint
Audio: Pioneer Z120BT~Boston Acoustics SR95 & SR65 / JL Slash 300amp~JL 10" Stealthbox / JL Slash 500amp~Backup Camera~Shock Sensor / Alarm
Old 01-24-2013, 07:33 AM   #4
RTGordon
 
RTGordon's Avatar
 
Posts: 3,765
Member #22113
Member since: Nov 2004
Location: Richmond, VA

My Corvette(s)
These tights make my butt look big.

Thanks: 1
Thanked 2 Times in 2 Posts
I don't know if you have a previous thread on this issue, so just starting with the basics: Will it make multiple pops in a tight, low speed turn? If so, the steering rack could be on its way out. If not, I can only imagine it is a tie rod end or ball joint issue.
RTGordon is offline   Reply w/quote Quick reply to this message
2000 Pewter/Black Coupe, gone.
1974 Blue/Silver Coupe, gone.
1982 Gold Coupe, gone.
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Corvette Forum : DigitalCorvettes.com Corvette Forums forums, you must first register.
Please enter your desired user name (12 CHARACTERS MAXIMUM), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Powered by vBadvanced CMPS v3.2.2

All times are GMT -6. The time now is 05:15 AM.




Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
2003-2011, DigitalCorvettes.com - All Rights Reserved