Clicking Sound When Brakes Applied - Corvette Forum : DigitalCorvettes.com Corvette Forums
 
 
Go Back   Corvette Forum : DigitalCorvettes.com Corvette Forums > C6 Corvette Forums > C6 Corvette
Register Forums Garage Garage Mark Forums Read Auto EscrowInsurance

Notices

C6 Corvette General | Technical | Performance | Aftermarket | Discussions

Other sections:
Corvettes Classifieds
Corvette Detailing & Car Care
Corvette Audio/Video/Radar
General Automotive/Shop/Tools
Corvette Performance Driving/Racing

Shops/Tuners
Custom Image Corvettes
A&A Corvette
Corvette tuner

Interior
Corvette aftermarket products

Insurance

Parts & Products
Race Ramps
Edelbrock
ATI/Procharger
Corvetteguys.com
Melrose Motorsports
Parts Taxi
Airaid
Mid America Motorworks
Pfadt Racing
Madvette Motorsports
Hi-tech Custom Concepts
Corvette aftermarket products
Corvette Garage
Corvette Parts and Accessories
Corvette Car Care Products
Corvette HID
Mid America Motoroworks

Tracks/Schools
Bob Bondurant School of High Performance Driving
Corvette driving school

Wheels/Tires
Cray Wheels

Services
BADWERKS.com
Reply
 
Thread Tools
Old 02-10-2013, 08:49 PM   #1
Duramax1
DC Crew
 
Posts: 8
Member #120877
Member since: Feb 2013
Location: DFW, Tx

My Corvette(s)
'13 Coupe

Thanks: 0
Thanked 0 Times in 0 Posts
Clicking Sound When Brakes Applied

My '13 is only 2 months old. Problem #1. With the engine running or with the key on accessories, and the auto tranny in Park, I get a clicking sound every time I apply the brake pedal. Every time I pump it, it sounds as if it is being transmitted through the shift lever. Problem #2. Sometimes, as I start it, and have my foot on the brake, I get a clicking sound similar to what the turn signal flasher makes. It may only do it for a few seconds or sometimes maybe 10 seconds or more. Or none at all. Service guy says they have not heard of such problems and can't duplicate it. Problem #1 just recently started and I have not taken it to the dealer yet. Any ideas appreciated. Thanks
Duramax1 is offline   Reply w/quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 02-15-2013, 08:22 AM   #2
Duramax1
DC Crew
 
Posts: 8
Member #120877
Member since: Feb 2013
Location: DFW, Tx

My Corvette(s)
'13 Coupe

Thanks: 0
Thanked 0 Times in 0 Posts
Had it in the shop yesterday for the above problems. They said #1 was common and was a lock out switch that lets you move it from Park.

#2 ended up being the HVAC mode actuator making the clicking noise. They replaced the actuator. It was mainly doing it in the AC Auto mode. Trying to keep it at the set temp and flopping around trying to make the corrections in temp. At least that is their story.
Duramax1 is offline   Reply w/quote Quick reply to this message
'13 Torch Red base model coupe
Auto tranny
Old 02-15-2013, 08:29 AM   #3
WNH
DC Crew
 
WNH's Avatar
 
Posts: 456
Member #11941
Member since: Apr 2004
Location: NJ

My Corvette(s)
1988, 2006

Thanks: 0
Thanked 4 Times in 4 Posts
Quote:
Originally Posted by Duramax1 View Post
, I get a clicking sound every time I apply the brake pedal. Every time I pump it, it sounds as if it is being transmitted through the shift lever.
I get that clicking noise with with my 2006, near the passenger side. It seems to be the brake relay, and from what I understand it's normal and not a malfunction.
WNH is offline   Reply w/quote Quick reply to this message
Old 02-20-2013, 10:47 PM   #4
Debo
DC Crew
 
Debo's Avatar
 
Posts: 235
Member #41150
Member since: Nov 2005
Location: El Paso,TX,USA

My Corvette(s)
C6 Corvette

Thanks: 0
Thanked 4 Times in 4 Posts
Quote:
Originally Posted by WNH View Post
I get that clicking noise with with my 2006, near the passenger side. It seems to be the brake relay, and from what I understand it's normal and not a malfunction.
I have this same clicking sound going on near the passenger side.
Debo is offline   Reply w/quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Corvette Forum : DigitalCorvettes.com Corvette Forums forums, you must first register.
Please enter your desired user name (12 CHARACTERS MAXIMUM), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Powered by vBadvanced CMPS v3.2.2

All times are GMT -6. The time now is 10:26 PM.




Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
2003-2011, DigitalCorvettes.com - All Rights Reserved