Corvette Forum : DigitalCorvettes.com Corvette Forums - Reply to Topic
 
 
Go Back   Corvette Forum : DigitalCorvettes.com Corvette Forums > C3 Corvette Forums > C3 Corvette > 1900 miles on motor and got a loud rattle
Register Forums Garage Garage Mark Forums Read Auto EscrowInsurance Advertise

Notices

C3 Corvette
C3 Corvette General | Technical | Performance | Aftermarket | Discussions

Other sections:
Corvettes Classifieds
Corvette Detailing & Car Care
Corvette Audio/Video/Radar
General Automotive/Shop/Tools
Corvette Performance Driving/Racing

( Sponsored by: Zip Corvette Parts )

Shops/Tuners
Custom Image Corvettes
A&A Corvette
Corvette tuner

Interior
Corvette aftermarket products

Insurance



Parts & Products
Race Ramps
Edelbrock
ATI/Procharger
Corvetteguys.com
Melrose Motorsports
Parts Taxi
Airaid
Pfadt Racing
Madvette Motorsports
Hi-tech Custom Concepts
Corvette Garage
Corvette Parts and Accessories
Corvette Car Care Products
Corvette HID

Tracks/Schools
Bob Bondurant School of High Performance Driving
Corvette driving school

Wheels/Tires
Cray Wheels

Services
BADWERKS.com
Thread: 1900 miles on motor and got a loud rattle Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Corvette Forum : DigitalCorvettes.com Corvette Forums forums, you must first register.
Please enter your desired user name (12 CHARACTERS MAXIMUM), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
City / State / Country?
Where you live
What kind of Corvette(s) do you own?
This field is not required.
Insurance
Please select your insurance company (Optional)

Log-in


Additional Options
Miscellaneous Options

Topic Review (Newest First)
09-06-2019 07:05 PM
grumpyvette did you find and isolate the issue?
09-06-2019 05:44 PM
madvette74
Quote:
Originally Posted by grumpyvette View Post
Thank you for the link
08-30-2019 07:50 PM
grumpyvette http://garage.grumpysperformance.com...t-noise.15694/
08-28-2019 03:04 PM
madvette74 Here is the passenger side. After looking at it. It looks like most valves are closed, these pics are about 5 degrees after tdc
08-28-2019 02:36 PM
madvette74 I noticed a slight rattle about 150 miles ago very subtle, I in no way drive the car hard.. I can rev the motor in neutral no rattle.. but when there is a load on the motor it will, so if I am driving by another car I can hear my car echo of it.. if I accelerate 25 to 50 percent I can her it clear and loud.. pretty dam loud, and my exhaust is loud.. now it gets louder the hotter the motor, but still wont make the the noise idling or 3000 rpm revs in neutral... I pulled the valve covers and intake, rotated the engine checking for loose rockers or a bent push rod, something that could tell me its in the valve train area... now the car is a 4 speed, 383 stroker, hydraulic roller cam and crane roller rockers... I dont want to risk engine damage or to my AFR heads.. has anyone come across this problem and or know what it could be?? Added a pic of drivers side.. Thst side sounds normal to me . the passenger side sounded louder.. That was the first side I wanted to check..

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Powered by vBadvanced CMPS v3.2.2

All times are GMT -6. The time now is 10:53 PM.




Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
2003-2011, DigitalCorvettes.com - All Rights Reserved