Corvette Forum : DigitalCorvettes.com Corvette Forums - Reply to Topic
 
 
Go Back   Corvette Forum : DigitalCorvettes.com Corvette Forums > C3 Corvette Forums > C3 Corvette > T56 in a c3 corvette figment issues and problems
Register Forums Garage Garage Mark Forums Read Auto EscrowInsurance Advertise

Notices

C3 Corvette
C3 Corvette General | Technical | Performance | Aftermarket | Discussions

Other sections:
Corvettes Classifieds
Corvette Detailing & Car Care
Corvette Audio/Video/Radar
General Automotive/Shop/Tools
Corvette Performance Driving/Racing

( Sponsored by: Zip Corvette Parts )

Shops/Tuners
Custom Image Corvettes
A&A Corvette
Corvette tuner

Interior
Corvette aftermarket products

Insurance



Parts & Products
Race Ramps
Edelbrock
ATI/Procharger
Corvetteguys.com
Melrose Motorsports
Parts Taxi
Airaid
Pfadt Racing
Madvette Motorsports
Hi-tech Custom Concepts
Corvette Garage
Corvette Parts and Accessories
Corvette Car Care Products
Corvette HID

Tracks/Schools
Bob Bondurant School of High Performance Driving
Corvette driving school

Wheels/Tires
Cray Wheels

Services
BADWERKS.com
Thread: T56 in a c3 corvette figment issues and problems Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Corvette Forum : DigitalCorvettes.com Corvette Forums forums, you must first register.
Please enter your desired user name (12 CHARACTERS MAXIMUM), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
City / State / Country?
Where you live
What kind of Corvette(s) do you own?
This field is not required.
Insurance
Please select your insurance company (Optional)

Log-in


Additional Options
Miscellaneous Options

Topic Review (Newest First)
09-28-2019 02:30 PM
slofut Tex, here's another t56 thread. I'm still working on paint even as we speak. Just dont spend as much time as I have...

https://www.digitalcorvettes.com/for...164292&page=14
09-14-2019 12:11 AM
zimmej51
Quote:
Originally Posted by texmanmoore View Post
I purchased a used 2006 gto t56 and the chance aftermarket weir adapter kit for clutch. When installed it does not center into the trans tunnel. Plus doesn’t fit into after market trans crossmember from G force model rcc3. Is this a common problem. And how to I correct it. I hate to start notching crossmember and trans tunnel to make it fit. Do I need to adjust engine motor mounts for figment. Is there a link or info you guys can share with me? Thanks for any feedback
Scott

Hi Texmanmoore; I see nobody has posted anything to your question so I'll throw out a few things. You didn't mention if you are using a conventional SBC or have swapped in an LSx or something. Also don't know what year your Corvette is.



Anyway, I'll share a few dimensions and things I learned on my project. It is a 1981 with factory 4-speed. I have done a complete frame off resto mod with an LS3 and a T-56 6 speed. I didn't have too much trouble getting things to fit but fabrication was necessary.


In order to get the T-56 shifter to line up with the original shifter "hole" in the console here is the setup I used:


The distance from the engine block/bell housing parting line to the rear face of the motor mount should be 13-1/4 inches. Here's a picture:



Next, I used an American Powertrain White Lightning short throw shifter with a 2-1/4" offset arm. The part number is SHWL-20313. This shifter allows the shift lever to stick out of the stock console almost exactly where the stock one did. Another pic...






It was necessary to significantly modify the cross member to fit the T-56 rear mount. I am not familiar with the cross member you bought and don't know the reasons it won't fit. In any case, I originally meant to chop up the original cross member to use as a pattern for a complete new one. For a while I considered using it but in the end I elected to fabricate a complete new cross member, mostly to make room for a true dual exhaust and to SLIGHTLY relocate the parking brake pulley. Here are some pics of the modified old one and the fabricated new one.














You can see the old modified cross member in the background. If your car is an 80-82 it should fit. If you are interested in the old one I can send it to you for free if you will pay the shipping. It's in my way and I have no further use for it.


As far as the up/down position of the transmission tail shaft, refer to post #108 in my build thread. It will provide you with some idea of how to position the tailshaft and minimize driveline vibration.


Hope this helps, If you need more details please let us know the specifics of your car. Good Luck!
08-18-2019 03:28 PM
texmanmoore
T56 in a c3 corvette figment issues and problems

I purchased a used 2006 gto t56 and the chance aftermarket weir adapter kit for clutch. When installed it does not center into the trans tunnel. Plus doesn’t fit into after market trans crossmember from G force model rcc3. Is this a common problem. And how to I correct it. I hate to start notching crossmember and trans tunnel to make it fit. Do I need to adjust engine motor mounts for figment. Is there a link or info you guys can share with me? Thanks for any feedback
Scott

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Powered by vBadvanced CMPS v3.2.2

All times are GMT -6. The time now is 04:39 AM.




Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
© 2003-2011, DigitalCorvettes.com - All Rights Reserved