Corvette Forum : DigitalCorvettes.com Corvette Forums

Corvette Forum : DigitalCorvettes.com Corvette Forums (https://www.digitalcorvettes.com/forums/index.php)
-   C5 Corvette - General Discussion (https://www.digitalcorvettes.com/forums/forumdisplay.php?f=76)
-   -   DIY - Replacing the C5 Water Pump (https://www.digitalcorvettes.com/forums/showthread.php?t=129941)

Junkman2008 10-28-2009 06:09 AM

DIY - Replacing the C5 Water Pump
 
Well folks, you get to benefit from another situation I found myself in. The day before I was supposed to drive to Arkansas from Kentucky, my water pump decides to reveal to me that it was leaking. I had been smelling antifreeze but it wasn't leaving any drops on the floor. Well, that finally changed at the most inopportune time.

Some info on how to check for a leaking water pump. First of all, if you smell antifreeze, you have a leak. Period. You may not see it, see coolant on the ground or be able to locate it but trust me, you have a leak. I think I have managed to have a leak in every possible common location:
  • The "T" connector located on the surge tank (it usually cracks).
  • The upper hose connector at the top of the radiator. It develops a hairline crack. There's a TSB that has you polish it out and not replace the radiator. I replaced my radiator instead because it had over 100,000 miles on it.
  • The water pump.

Here's the deal with detecting a water pump leak on the C5. The fluid will not drop to the floor directly under the water pump unless you have a really heavy leak. It will land on the belt or belt pulley and sling to one side of the car (most likely the driver's side because of the direction that the belt travels). I didn't know that as I kept checking dead center of the engine on the garage floor. My leak was extremely small up until the point that I actually found it. Hey, I'm old school and my previous experience taught me to check dead center of the engine on the garage floor. Now I know better. :lookinup:

This turned out to be a rather easy repair compared to some that I have done. I would easily recommend a shade tree mechanic take this on as long as you have one very important tool: hose clamp pliers. Don't even attempt this repair without them as there are quite a few hose clamps that you have to remove. Those things will take you forever to remove with a pair of pliers. Don't waste your time, buy a nice pair of hose clamp pliers with the extension cable. You'll thank me later. You'll see them in the pictures below.

With all that said, let's get to the repair!

Tools needed:
  • Hose Clamp Pliers
  • 3/8" 10mm Socket and Ratchet
  • 3/8" 15mm Socket
  • Flat Head Screwdriver
  • Dielectric Grease or Vaseline
  • Radiator Hose or White Lithium Grease
  • Safety Glasses
  • Another socket for the thermostat bolts but I forgot what size it was! :lookinup:
  • These instructions! :thumbsup:

This repair should only be done when the engine is cool or cold.


Step 1: Remove the air cleaner intake duct. This is actually done as a unit. You don't have to remove the entire thing as I did, you can just remove the air bridge but for me, it was quicker just to remove the whole thing since I know how. Here it is removed:

http://i257.photobucket.com/albums/h...cts/wpump1.jpg

To do this, pop up the pins that hold the air bridge onto the radiator shroud.

http://i257.photobucket.com/albums/h...rad_clean4.jpg

Unplug the mass airflow (MAF) sensor connector. Once you get it unplugged and the harness is disconnected from the clip that holds the harness down, move it toward the back of the engine out of your way.

http://i257.photobucket.com/albums/h...cts/wpump3.jpg

http://i257.photobucket.com/albums/h...cts/wpump4.jpg

http://i257.photobucket.com/albums/h...ad_clean9a.jpg

Remove the air filter in order to make the next step simpler. As you can see, I'm a firm believer in the K&N filter.

http://i257.photobucket.com/albums/h...cts/wpump5.jpg

This next part is kind of tricky the first time you do it. The air cleaner intake duct is held onto the front frame cross-member by 2 rubber grommets. The air box just pushes on and pulls off. The first time you do it is like pulling teeth because you really have to give it a tug. It gets easier to do once you've done it before. See pictures below.

http://i257.photobucket.com/albums/h...cts/wpump6.jpg

http://i257.photobucket.com/albums/h...cts/wpump7.jpg

You will also need to unplug the Secondary Air Injection (AIR) hose. The bottom part of that hose simply pulls apart from the top part if you twist it back and forth.

http://i257.photobucket.com/albums/h...cts/wpump8.jpg

Last of all, loosen the screw that holds the air bridge onto the throttle body.

http://i257.photobucket.com/albums/h...ts/wpump3a.jpg

Once you get all this stuff disconnected, separated and unplugged, the air cleaner intake just simply lifts out of the engine bay. Put it to the side.


Step 2: The first thing you need to do here is look at how the accessory belt is routed. Take pictures of it from various angles so that you will have something to look at when it comes time to put it back on. That's what I do before disassembling anything.

Remove the accessory belt from the accessory tensioner pulley and allow it to drop toward the bottom of the engine. There is no need to remove it all the way so don't make more work by doing so. To remove it, use the 15mm socket and rotate the pulley clockwise (toward the driver's side), until you can slip the belt off the tensioner.

http://i257.photobucket.com/albums/h...cts/wpump9.jpg

http://i257.photobucket.com/albums/h...ts/wpump10.jpg

Step 3: Drain the cooling system. In order to do this, you will need to raise the car. for those who don't have a lift, here's the way I do it.

A) Drive the front of the car up on some 2X12's.

http://i257.photobucket.com/albums/h.../brakejob2.jpg

B) Using a low profile jack that I got from Harbor Freight, I center a 2X4 on the jack plate and run it under the front of the car.

http://i257.photobucket.com/albums/h...ts/wpump12.jpg

http://i257.photobucket.com/albums/h...ts/wpump13.jpg

http://i257.photobucket.com/albums/h...ts/wpump14.jpg

Once in place and lifted, I support the car with jack stands.

http://i257.photobucket.com/albums/h...ts/wpump15.jpg

I follow the same exact procedure for the rear of the car, making it slightly higher for draining purposes.

Warning: Pay special attention to the front jacks as you raise the rear. They could topple over if you get to extreme with your lift height!!!

http://i257.photobucket.com/albums/h...ts/wpump16.jpg

Now I have all kinds of room to work under the car. :D

http://i257.photobucket.com/albums/h...ts/wpump17.jpg

Remove the overflow tank cap and get your safety glasses on. Remember, safety first! :thumbsup:

http://i257.photobucket.com/albums/h...ts/wpump18.jpg

http://i257.photobucket.com/albums/h...ts/wpump19.jpg

The actual draining of the system is pretty easy. You simply loosen the drain cock (hey, I didn't name it... that's what it's called) and you will see the fluid begin to flow. You will turn it counter-clockwise. Do not completely remove the drain cock, just loosen it until the antifreeze starts flowing real good. Now go have Dagwood Pizza and your favorite drink because it will take the fluid a little bit to completely drain.. :D

http://i257.photobucket.com/albums/h...ts/wpump20.jpg

http://i257.photobucket.com/albums/h...ts/wpump21.jpg

Once all of the coolant has drained, close the drain cock and lower the car. You can reuse your old coolant if you want to but if it wasn't changed recently, I don't know why you would. Don't be a cheap azz, buy some new fluid for your baby. Don't get the 50/50 stuff because you're paying for water, which is free (however, if you don't have access to distilled water, buy the 50/50 stuff). Other than that, buy the full strength stuff and dilute it with distilled water. You can use A 50/50 mixture of clean, drinkable water but use only GM Goodwrench® DEX-COOL® or Havoline® DEX-COOL® silicate-free coolant. It takes approximately 11.9 liters (12.6 quarts) to refill the cooling system.

Junkman2008 10-28-2009 06:09 AM

(con't)

Step 4: Get out your hose clamp pliers and reposition the inlet and outlet hose clamps at the water pump. See pictures below.

http://i257.photobucket.com/albums/h...ts/wpump22.jpg

http://i257.photobucket.com/albums/h...ts/wpump23.jpg

http://i257.photobucket.com/albums/h...ts/wpump24.jpg

http://i257.photobucket.com/albums/h...ts/wpump25.jpg

http://i257.photobucket.com/albums/h...ts/wpump26.jpg


Step 5: Remove the inlet and outlet hoses from the water pump if you haven't already done so.

Step 6: Reposition the heater inlet and surge tank outlet hose clamps at the water pump. See pictures below.

http://i257.photobucket.com/albums/h...ts/wpump28.jpg

http://i257.photobucket.com/albums/h...ts/wpump29.jpg

http://i257.photobucket.com/albums/h...ts/wpump27.jpg


Step 7: Remove the heater inlet and surge tank outlet hoses from the water pump, as per directions in the pics above (if you haven't already done so).

Step 8: In this order, remove the thermostat bolts (2), the accessory tensioner bolts (2) and the water pump bolts (6). One thing that I always do is ensure that I put the bolts I remove back into the exact hole that they came out of, especially when dealing with aluminum engine parts. Call me crazy, I have my reasons. If you want to do that also, make sure you keep track of the bolts as you remove them. Check the picture below.

http://i257.photobucket.com/albums/h...ts/wpump30.jpg

Step 9: Remove the water pump. Nothing tricky here, just wiggle that chunk of metal out of there. Make sure you remove the water pump gaskets if they don't come off with the old water pump.

Clean up the area where all that Dex-Cool has leaked. You want to be able to detect any new leaks. I used Brakleen from CRC to clean up engine dirt. That stuff is good but you will need about 3 cans. You can go through that stuff pretty fast and it is not exactly cheap.

Now you're ready for the new pump. The new pump comes with the gaskets for the water pump and thermostat. The ones for the water pump are paper, which is NOT what comes stock on your car. Don't use the paper ones that come with the new pump, go buy the original GM gaskets. They only cost me $23, well worth the extra quality. Here's the gaskets and new part numbers as of this posting. You will need 2 gaskets (same part number).

http://i257.photobucket.com/albums/h...ts/wpump31.jpg

http://i257.photobucket.com/albums/h...ts/wpump32.jpg

You can use the rubber gasket that comes with the water pump for the thermostat. Just make sure that you replace that t-stat gasket!

http://i257.photobucket.com/albums/h...ts/wpump33.jpg

http://i257.photobucket.com/albums/h...ts/wpump34.jpg


New water pump. I paid about $180 at O'Reilly's for a brand spankin' new one.

http://i257.photobucket.com/albums/h...ts/wpump35.jpg

http://i257.photobucket.com/albums/h...ts/wpump36.jpg


Now all you have to do is reverse the installation process. Here's the fun hurdle that you will run into. Trying to keep the water pump gaskets in place as you line up the mounting screws and water pump. I could have used some type of grease to make the gasket stick to the motor or the water pump itself but I didn't know what was safe to use ( I didn't want to create any leaking issues). Thus, I spent the next two hours trying to do it without any help. It was a bitch.

Once I got it on, I went in and had another pizza. :smokin:

One helpful tip: Use the dielectric grease or Vaseline on the rubber grommets that attach the air box to the front cross-frame. The grease will make it easier to snap back on. Use some radiator hose or White Lithium grease on the inner lip of the hoses to help ease the installation of them. DON'T use a lot. A teeny, weenie bit goes a long way.


Here are your torque settings for all the bolts.
  • Tighten the water pump bolts a first pass to 15 N·m (11 lb ft). Tighten the water pump bolts a final pass to 30 N·m (22 lb ft).
  • Tighten the accessory drive belt tensioner bolts to 50 N·m (37 lb ft) starting with the lower bolt first.
  • Tighten the water pump inlet bolts (thermostat) to 15 N·m (11 lb ft).

That's it folks. It looks like a complicated job because I'm long winded and took a lot of pictures but it really is an easy fix if you don't know how to work on your Vette. With these instructions, anyone can do it.

Holler if you have any questions! :)


The Junkman

RTGordon 10-28-2009 07:07 AM

Very nice write-up! It's all about using the right tools for the job. I'm just thankful that you don't have to remove the damper to get to it.
:thud:

alini 10-28-2009 09:37 AM

I wouldnt have figured it was that easy. Thanks for the write up, great job as always

krazytrain 10-28-2009 11:49 AM

Another great write up :thumbsup: Im gonna have to save this one.

mikec4c5 10-28-2009 02:38 PM

Another awesome writeup AJ !! Dayum, I spent so much time looking at, and reading this DIY that I feel like I just changed a WP all while sitting here on my azz with my feet up on the desk !! I need a break dude..... :D

Here's something I never knew existed:
hose clamp pliers

I've always used big lock pliers to remove these style hose clamps.
-Does this tool work well in areas that are space limited ??
-Does Harbor Freight sell this tool ??

Thanks for the great info. I've changed a bunch of C4 WP's, but never a C5. I'm sure the day is approaching though...

(oh, I gotta' ding ya' for putting your MAF and airduct assembly on your roof top !!!! Bad man....Bad man ......bwah hah hah j/k)

:thumbsup:

Junkman2008 10-28-2009 03:03 PM

Quote:

Originally Posted by mikec4c5 (Post 1564294)
Another awesome writeup AJ !! Dayum, I spent so much time looking at, and reading this DIY that I feel like I just changed a WP all while sitting here on my azz with my feet up on the desk !! I need a break dude..... :D

Here's something I never knew existed:
hose clamp pliers

I've always used big lock pliers to remove these style hose clamps.
-Does this tool work well in areas that are space limited ??
-Does Harbor Freight sell this tool ??

Thanks for the great info. I've changed a bunch of C4 WP's, but never a C5. I'm sure the day is approaching though...

(oh, I gotta' ding ya' for putting your MAF and airduct assembly on your roof top !!!! Bad man....Bad man ......bwah hah hah j/k)

:thumbsup:

That is my old roof. I have a new one now. :thumbsup: :D

There are 2 types of hose clamp pliers. One has a cable (great for getting into limited space areas), and the kind without the cable (okay for working in open areas). I would only buy the cable type. They are more expensive but they work in both areas really well. More than worth the money, if you have spent time bent over the fender trying to get a pair of pliers to work. All it took was for me to experience that once in a Auto Zone parking lot and never again. :down:

I got mine at Sears for $40.00. They also have the SK brand for $104.00, but you would have to be smoking crack to buy those.

Randypalooza 10-28-2009 03:34 PM

Wow, great write up Junkman! I know I'll be needing this one at some point in time. I haven't had to do this yet, but your step by step makes it easy. Thanks.:partyon:

BWF07 10-28-2009 03:42 PM

You Da Man AJ Great writeup. Oh by the way I like the hat.

jmaal13 10-28-2009 03:48 PM

For me, the coolant dripped on the belt which caused it to squeal which led me to the bad Water pump. Good DIY.

:thumbsup:

Junkman2008 10-28-2009 03:53 PM

Quote:

Originally Posted by TR6Speed (Post 1564351)
You Da Man AJ Great writeup. Oh by the way I like the hat.

That's called a "cover"! http://www.pc-surgeon.net/images/cfo...eys/toetap.gif



:laughing:

Fly03Z06 10-28-2009 04:26 PM

Well Done AJ :thumbsup:
Just curious, how does the O'Rileys water pump manufacturer compare to OEM for fit, finish availablity and price? Understand you did this prior to a road trip, how easy was it to locate................in a hurry?

.........and approximately, what mileage were you at when you first noticed you might of had a leak?

raidmagic 10-28-2009 04:27 PM

Can I offer one thing? If you have the stock style spring clamps PLEASE PLEASE PLEASE replace them when you do this with either new ones or the more prefered wormdrive type. I just about blew the motor in my truck recently when I replaced the radiator and the bottom hose clamp decided to not clamp anymore and the hose came off. They are only a few bucks and don't depend on pressure to stay on the car, they tighten.:thumbsup:


Also the pump replacement in my car with the LS was super easy, I didn't even need to remove the intake:laughing: God love a C4.

strider67109 10-28-2009 04:29 PM

great job!
 
Your the man!!! Thanks for the great writeup with lots of pics.

oaks99 10-28-2009 05:09 PM

once i take those bastards off they go straight to the trash can , and get brand new hose clamps that you use a nut driver to remove and tighten , i know they are not oem :D


oak


All times are GMT -6. The time now is 07:24 PM.

Powered by vBulletin® Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.

vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
© 2003-2011, DigitalCorvettes.com - All Rights Reserved