C6 2005 Manual Transmission Swap - Corvette Forum : DigitalCorvettes.com Corvette Forums
 
 
Go Back   Corvette Forum : DigitalCorvettes.com Corvette Forums > TECH Exchange > Articles - Engine, Other
Register Forums Garage Garage Mark Forums Read Auto EscrowInsurance Advertise

Notices

Articles - Engine, Other Everything else relating to engines

Shops/Tuners
Custom Image Corvettes
A&A Corvette
Corvette tuner

Interior
Corvette aftermarket products

Insurance



Parts & Products
Race Ramps
Edelbrock
ATI/Procharger
Corvetteguys.com
Melrose Motorsports
Parts Taxi
Airaid
Pfadt Racing
Madvette Motorsports
Hi-tech Custom Concepts
Corvette Garage
Corvette Parts and Accessories
Corvette Car Care Products
Corvette HID

Tracks/Schools
Bob Bondurant School of High Performance Driving
Corvette driving school

Wheels/Tires
Cray Wheels

Services
BADWERKS.com
Reply
 
Thread Tools
Old 11-01-2013, 07:35 PM   #1
BHat
DC Crew
 
Posts: 1
Member #133842
Member since: Nov 2013
Location: Florida

Thanks: 0
Thanked 0 Times in 0 Posts
Unhappy C6 2005 Manual Transmission Swap

Hello all,
I'm in the process of converting my Auto C6 to a manual, and ran into a problem with the electronic portion of the conversion. Right now I cannot get the engine to turn over. So far I did the following: Removed the TCM, bypassed the GM LAN wires that looped through the trans harness, installed a clutch start switch (wired according to schematics in the service manual), used a Tech 2 to turn on the "manual transmission" option in the BCM, and installed a new ECM with the calibrations for a manual vette. When I press the start button the instruments light up, but the needles don't sweep to full scale like they used to. And the engine doesn't turn over. I scanned for codes but didn't find anything in troubling the ECM. What am I missing here?
When I put the TCM and old ECM back and turn off "manual trans " in the BCM the car will start.
BHat is offline   Reply w/quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 11-01-2013, 10:44 PM   #2
Longtimer
DC Pit Crew Boss
 
Longtimer's Avatar
 
Posts: 10,024
Member #3668
Member since: Nov 2003
Location: So Cal

My Corvette(s)
'07 Z51 6Mn NCM delivery, '79 L82 4 sp gymk - Gone '87 Z52 4+3, 76 L-82 4 spd

Thanks: 523
Thanked 504 Times in 363 Posts
I've moved your thread here because you are more likely to get an informative reply in this section. I'd help if I could, but you've already passed my knowledge level. Hope you get the problems resolved quickly.
Longtimer is offline   Reply w/quote Quick reply to this message
Corvette ownership is like owning your own fountain of youth ... and we get a sip from it each time the signal turns green.
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Corvette Forum : DigitalCorvettes.com Corvette Forums forums, you must first register.
Please enter your desired user name (12 CHARACTERS MAXIMUM), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
City / State / Country?
Where you live
What kind of Corvette(s) do you own?
This field is not required.
Insurance
Please select your insurance company (Optional)

Log-in


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Powered by vBadvanced CMPS v3.2.2

All times are GMT -6. The time now is 07:12 AM.




Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
2003-2011, DigitalCorvettes.com - All Rights Reserved