1988 C4 Corvette convertible code 43 and More - Corvette Forum : DigitalCorvettes.com Corvette Forums
 
 
Go Back   Corvette Forum : DigitalCorvettes.com Corvette Forums > C4 Corvette Forums > C4 Corvette
Register Forums Garage Garage Mark Forums Read Auto EscrowInsurance Advertise

Notices

C4 Corvette General | Technical | Performance | Aftermarket | Discussions

Other sections:
Corvettes Classifieds
Corvette Detailing & Car Care
Corvette Audio/Video/Radar
General Automotive/Shop/Tools
Corvette Performance Driving/Racing

Shops/Tuners
Custom Image Corvettes
A&A Corvette
Corvette tuner

Interior
Corvette aftermarket products

Insurance



Parts & Products
Race Ramps
Edelbrock
ATI/Procharger
Corvetteguys.com
Melrose Motorsports
Parts Taxi
Airaid
Pfadt Racing
Madvette Motorsports
Hi-tech Custom Concepts
Corvette Garage
Corvette Parts and Accessories
Corvette Car Care Products
Corvette HID

Tracks/Schools
Bob Bondurant School of High Performance Driving
Corvette driving school

Wheels/Tires
Cray Wheels

Services
BADWERKS.com
Reply
 
Thread Tools
Old 09-30-2019, 02:00 PM   #1
Vortex1977
DC Crew
 
Posts: 2
Member #181580
Member since: Jul 2019

Thanks: 0
Thanked 0 Times in 0 Posts
1988 C4 Corvette convertible code 43 and More

Hi guys

I have a few small problems with my C4

The first one is a wire behind the steering that smoked and now is disconnected . The entire plastic is melted and the wire is now disconnected
I had some smoke and I turned off the engine as fast as I can

later I try starting the engine and no problem manifested

I checked everything

Light and blinkers horn radio
Car is driving fine

Second problem

When I accelerate I get some hesitation and lack of power . And when I drive I can hear some pre detonation I think

First thing I did was a tune up
I replaced all the plugs and wires
Oil filter and ideal control module in the throttle body . I removed the throttle body and clean up everything and put back with a new gasket

Problem still happening

Then I found code 43 so I was thinking bad knock sensor
I replaced yesterday but still having the same problem

I was not sure if I need to reset the ECM after I replaced the knock sensor

I will try today

Was wondering if this burned wire behind the steering is the problem

It's not easy for me to follow without taking apart the entire dash

Any help is appreciated
Vortex1977 is offline   Reply w/quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Corvette Forum : DigitalCorvettes.com Corvette Forums forums, you must first register.
Please enter your desired user name (12 CHARACTERS MAXIMUM), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
City / State / Country?
Where you live
What kind of Corvette(s) do you own?
This field is not required.
Insurance
Please select your insurance company (Optional)

Log-in


Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Powered by vBadvanced CMPS v3.2.2

All times are GMT -6. The time now is 11:01 PM.




Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
2003-2011, DigitalCorvettes.com - All Rights Reserved