Corvette Forum : DigitalCorvettes.com Corvette Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Can anyone help. I have a 95 LT1 and DTC 18 is setting. It makes the engine run slightly rough and it is making DTC 55 set. 18 is Injector Circuits, and 55 is fuel lean. 18 is forcing the motor to run lean. I have checked the injector harness with noid lights and everything checked out ok. The injectors physically look clean when taken out, and ohm test places every injector within .2ohms from each other. Any common issues I should know about?
 

·
Registered
Joined
·
283 Posts
You need to run an injector balance test. I guess if you don't have a scan tool you can disconnect each injector while it's running and see which cylinder doesn't have an RPM drop. That'll be the circuit with a fault. Also, you need a noid light to see if all the injectors are getting fire from the PCM.[EDIT] Getting ground from the PCM to fire the injectors.
 

Attachments

·
Registered
Joined
·
2 Posts
Discussion Starter #4
Thanks for your Submission

I appreciate you getting back so quick, but I figured out my issue with some more toying. I pulled the injector rail out and re-oiled the bottom injector o-rings and re-seated them. Apparently I had a vacuum leak through the injector port and it was causing a misfire. Car runs great and has never had more HP. Thanks for the post. If you could send me an email at [email protected] so I can get some info from you, because you have a good idea about how a motor works. I'd like to see about involving you in a project I have in development for home automotive instruction. Thanks Again
 
1 - 4 of 4 Posts
Top