Corvette Forum : DigitalCorvettes.com Corvette Forums banner
1 - 5 of 5 Posts

· Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
Hello guys. First of all excuse me for not writting very well in English.

I have a problem with a C5. It isn't mine but I'm driving it day by day and I'm going to buy it (because of the very good price) but only if I fix this problem.

It doesn't let me go over 128kmh and on the error display it gives me something about "Check suspension system" or "Check Active Handling". The problem is that I don't have Active Handling on it ... It doesn't even have the "On-Off" Active Handling button ...

It was produced in 1998 and it has Z06 wheels ..

Can somebody tell me wich is the standard suspension on the 1998 C5 Corvettes and what should I do?

Thank you very much !
 

· Registered
Joined
·
965 Posts
Good luck getting an answer. My last 5 posts have gone with no replies. I feel DC has lost a few guys who know tech about c5's..... My assumption with your car is it sounds like possibly a module went bad at some point in the cars life and they replaced it with a used module from another car? Thats why the car would not have the option but the module is searching for it. It can be programed out by a GM dealer. Also theirs a sticky about pulling codes. Find out what codes you may have in the modules you may have an abs code or something related to the suspension that could cause the issue. Good Luck
 

· Registered
Joined
·
10 Posts
Discussion Starter · #3 ·
This Monday I'm going to meet a guy who has a diagnostic scanner for the C5 and maybe he could fix the issues. I also received the message that the car will not go over 128kph (80mph) until I'll fix it. The funny thing is that the car works very good, it doesn't seems to have any issue ...

A friend of mine have almost the same issue with a '03 50th Anniversary. Everything started because of a strong brake for avoiding a car crash and after this strong brake, a full throttle start ... Immediatly all the existing lights and every existing error on the dashboard switched on.

Another suspicios thing is that I didn't find the Option Code wich on the 97-98 models should be on the cover of the left rear storage compartment, but, surprise, it isn't there ... not even in the glove box as in the newer models
 

· Registered
Joined
·
608 Posts
Post the VIN # and we can then see what features and options it came with

You really need a OBD-II scanner then can connect to the EBCM and the BCM to see what looks odd.

Check wheel speed sensors, wiring to the EBCM, check the error codes current and history.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top