Corvette Forum : DigitalCorvettes.com Corvette Forums banner
1 - 11 of 11 Posts

·
Registered
Joined
·
109 Posts
Discussion Starter · #1 ·
Started up the C6 this AM. Fuel gage went up to full (filled it last night), then back to empty-bells ringing "Service Fuel System"-low fuel.:thud:

This has been a problem with others, right? what will the dealer need to do to fix?
 

·
Registered
Joined
·
104 Posts
Started up the C6 this AM. Fuel gage went up to full (filled it last night), then back to empty-bells ringing "Service Fuel System"-low fuel.:thud:

This has been a problem with others, right? what will the dealer need to do to fix?
Check your gas cap to make sure it's on tight. Good chance that's the problem.
 

·
Registered
Joined
·
109 Posts
Discussion Starter · #3 ·
Tried the gas cap first thing--nope--the gage still reads empty and the service fuel susyem-low fuel is illuminated:lookinup:
 

·
Registered
Joined
·
109 Posts
Discussion Starter · #5 ·
That's what my guess is too. Gonna take it in Tuesday or wednesday and have it checked out.
 

·
Registered
Joined
·
14 Posts
With the fuel system light on you will need to replace the fuelsender unit on the right hand fuel tank, there is a TSB on theis problem and it is covered under the warranty of your vehicle, let the Chevrolet Tech's do this as it is rather involved because of the removal of the fuel tank.
 

·
Registered
Joined
·
109 Posts
Discussion Starter · #7 ·
I thot there was something out there about this being a known problem. Thanks. Taking her in Tuesday morning.:cheers:
 

·
Registered
Joined
·
20 Posts
Gas Guage Issue

There was an issue of the fuel gauge sender running off the read band when the tank was filled to far. The computer reads that as a fault and drives the gauge to zero. Try driving the car a little - 10 or 15 miles to use some of the fuel in the tank. If the gauge suddenly begins reading again, then take the car to the dealer and they will reflash your computer to tell the computer to ignore that particular fault. If the gauge remains at zero, then you may have to have the dealer replace your sending unit.

One thing to remember with a C6 - don't "pack" the gas tank. In other words when the nozzle shuts off the first time - stop. Don't try to get just a littel bit more into the tank.

Hope that helps:D,
ED
 

·
Premium Member
Joined
·
13,918 Posts
I was going to say the fuel sending unit (someone already said it). I had a very similiar problem in my 2000 Vette and that took care of it. Good Luck:thumbsup:
 

·
Banned
Joined
·
334 Posts
My '05 did that

You would think they would have fixed it by now.

Three things(possibilities)


1) Download new software from internet(chevy) Dealer did this to mine
2) Remove gas tanks replace sensor and all that crap. This will need the
best guy at your dealership
3) The TSB said that the computer board wasn't painted with coating enough
Replace.

Hopefully its just the software.

Maybe I got screwed time will tell I guess.

ww:thud:
 
1 - 11 of 11 Posts
Top