Corvette Forum : DigitalCorvettes.com Corvette Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
158 Posts
Discussion Starter #1
This morning I noticed a weird smell while driving to work, you know like somebody is heating up the room you're in. I check AC on driver's side and it cools. Then after a while I check the passenger side and warm air is coming out. WTF ?!? ... I turned the temp to lowest possible and ALSO the passenger side button to even "more" cold (dual side you know). It doesn't matter, passenger side always heating the room :thud: .

Tell me somone had this problem before.... I really don't have the will to tear the whole AC system appart to solve this one.... :spanked:
 

·
Premium Member
Joined
·
17,444 Posts
We got any A/C experts out there....?
 

·
Grey Squirrel
Joined
·
22,780 Posts
This morning I noticed a weird smell while driving to work, you know like somebody is heating up the room you're in. I check AC on driver's side and it cools. Then after a while I check the passenger side and warm air is coming out. WTF ?!? ... I turned the temp to lowest possible and ALSO the passenger side button to even "more" cold (dual side you know). It doesn't matter, passenger side always heating the room :thud: .

Tell me somone had this problem before.... I really don't have the will to tear the whole AC system appart to solve this one.... :spanked:

Sounds to me like the right air temperature actuator is not functioning properly. Any stored codes?
 

·
Registered
Joined
·
158 Posts
Discussion Starter #4
well, later in the afternoon as I drove back home, AC went back to normal ... I have NO idea why would that happen. I thought AC was broke. Eh... I'll pray that was just an electronic onetime bug....

thanks for the response, sometimes "we" react too quickly, cause we care about our "babies" :laughing:
 

·
Registered
Joined
·
189 Posts
The actuator door gets stuck sometimes. You can do a quick fix by pulling fuses 18 and 27 in the passenger fuse box before starting the car, then replacing them. It resets the system. It may be a sign of the actuator going downhill though. Mine did that for about a year until it finally gave out. The good thing is the actuator is only about $150, it just takes a little time getting to it.
 

·
Registered
Joined
·
1,938 Posts
mine did the exact same thing 2 weeks ago. Its been fine since then.
 
1 - 7 of 7 Posts
Top