Corvette Forum : DigitalCorvettes.com Corvette Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
38 Posts
Discussion Starter #1
hey all.. how u vettes doin? .... :cheers:

so..i was cruising in my vette (94 LT1 Auto) with the Ac is on, suddenly the AC start blowing hot air istead of cold..!!!! i took it to the chevy dealer (GM) and shockenly they told me i need to change the following:

- Evaporater Core
- Condenser.
- Drier.
- Orfice Tube
- Cooling fan motor RHS
- Low pressure switch.

and it will cost $2000+ ..!!??:lookinup: .. is that even possible?? i really need a help here.. coz in couple of days i have to answer t him if to go with it or not.!!

Thanks
 

·
Registered
Joined
·
914 Posts
I am a GM tech and it sounds like a rip off to me. I would like to know why you need to replace all these parts at once? did you put radioactive freon in your AC?:crazy:
 

·
Registered
Joined
·
441 Posts
Last year mine was doing the same thing..I stopped by an "Ice Cold Air" franchise near me who I heard was honest (Ha Ha) and they came up with an estimate for $1600 bucks to replace much of what was on your list even though they could NOT pinpoint the leak(so they said).........I replaced the AC schrader valve where you put the 134A(freon) in to fill it ...then filled it with nearly 3 small cans of 134A(with leak sealer inside) and that was about 7 months ago, and my air is still working like new...........Now Im not assuming that you had the exact same issue as mine(sine ALL kinds of issues can go wrong in an Air conditioning system), but for the cost of a 3 dollar (VERY common to fail) AC shrader valve, and a few cans of 134A(with sealer) it may be worth a try.....and as far as the electric fans themselves.....see if their working by getting your car up to full operating temp, with the air on....if one is broken, it's pretty easy to install that yourself(if you wanted)........good luck with it.......Joe:thumbsup:
 

·
Registered
Joined
·
38 Posts
Discussion Starter #4
thanks guy.. no i didnt put any freon!! thats why i was shocked.. when they told me that on the phone i was like..:WTF how could that happen in a sudden!!!! i suspected that could be only freon thats why i took it to GM .. but they didnt even mention freon they just said u need to replace the parts (in the list)..!!!

i'll try the freon in another place and check the fan...i hope thats all it need..coz wihout the AC here where i live its like sitting in an oven:lookinup:

any other reasons..or suggestions?? i really appreciate it..:cheers:

thanks
 

·
Registered
Joined
·
83 Posts
Have someone turn on your AC while you are under the hood and check the compressor cycle interval, usually if it is has an erratic cycle or no cycle at all it is a good indication of low refrigerant. Sometimes a charge of refrigerant and oil is all that is needed. An initial estimate of 2 grand deserves a second opinion. Good Luck!
 

·
DC Crew
Joined
·
4,751 Posts
This is going to sound odd, but disconnect your battery for a few seconds, reconnect, and try the a/c out.

The system has a fail safe mode that will shut it down if it is cycling too often (due to low freon, etc).

If it works, then you are simply low on freon.

It is a 94 model? If so, you have 134 in there already. Get a recharge can at your local auto part store and shoot a little in - watch the gauge on the recharge kit and follow the instructions to make sure you don't overcharge.

You should be good to go for the rest of the summer.

And...since I just saved you $1,989.00...you can buy me a cold drink some day with your savings... :cheers:
 

·
Registered
Joined
·
38 Posts
Discussion Starter #7
thanks a lot guys...im starting to feel a bit better now...coz the past 2 days im calling the dealer to explain the details ..and all i get is "they need to be changed"!! so i took my car out....

so i guess ill try what u told me guys and see if it will work.. but one more thing though!!.. where is the inlet for the freon to charge it..is it easy done?, i can do it..or should i take it to a shop to do it... and what is eaxactly the freon required for my vette.. its 94 LT1 AutoTrans.


thax a $2000 guys...drinks on me.. if it worked :cheers:
 

·
Registered
Joined
·
441 Posts
thanks a lot guys...im starting to feel a bit better now...coz the past 2 days im calling the dealer to explain the details ..and all i get is "they need to be changed"!! so i took my car out....

so i guess ill try what u told me guys and see if it will work.. but one more thing though!!.. where is the inlet for the freon to charge it..is it easy done?, i can do it..or should i take it to a shop to do it... and what is eaxactly the freon required for my vette.. its 94 LT1 AutoTrans.


thax a $2000 guys...drinks on me.. if it worked :cheers:
As mentioned ,you have 134A(but confirm this on your AC blower sticker) ....you can get it at pretty much any auto parts store......get a BIG can(the ones about 10inches high) "WITH" the gauge and filling hose included in the package, PLUS purchase one small can of 134A.....this way you will have a way to fill it(and enough 134A quanity).....follow the directions on the package for filling....your fill location is under the black cap on your AC lines(black cap "closest" to the passenger side wheel)........but like I said in my first post....pick up a new AC shrader valve(and installation tool).....you can also get these for a few bucks at any auto parts store, just tell the guy behind the counter what your doing and that you want to replace your valve as well(where the 134A goes in).....like I said, MANY times after several years goes by, these start to leak the freon out of the system, causing the system to blow hot instead of cold....after all.. there is a definite reason(possible leak) somewhere in the system "if" the 134A(freon) is low .......point being: just putting the 134A in without at least replacing the valve(I mentioned) may just be a waste of 20 plus dollars of 134A..........Joe:thumbsup:
 

·
Registered
Joined
·
38 Posts
Discussion Starter #9
thansk Joe:thumbsup: .. ill try that ... and ill be posting the results..:D

By the way.. any ideas about intercooler?? to keep it from heating coz my vette runs on 230-235f most of the times... and power goes:down: same as the responce!!

the weather here is unbelievable.. it goes up to 105-110f in normal summer day!!:crazy:

thx alot :cheers:
 
1 - 9 of 9 Posts
Top