Corvette Forum : DigitalCorvettes.com Corvette Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
741 Posts
Discussion Starter #1
I got all my vac doors and such working now, and max AC is working fine etc, Thank you big2bird, mrvette 6footer,and 6880 mike, but heres a strange thing.

The upper vents, there are two. The tube that feeds them there is one, its a wide tube and does not seem to have seperate compartments for the left and right side center vent. But I am getting little to no air from the right center vent with good flow from the left. Now WTF? Does this s--- make any since to anyone?
 

·
Registered
Joined
·
5,916 Posts
I got all my vac doors and such working now, and max AC is working fine etc, Thank you big2bird, mrvette 6footer,and 6880 mike, but heres a strange thing.

The upper vents, there are two. The tube that feeds them there is one, its a wide tube and does not seem to have seperate compartments for the left and right side center vent. But I am getting little to no air from the right center vent with good flow from the left. Now WTF? Does this s--- make any since to anyone?
All I can think of is debri blocking 1 vent. Got a flash light?
 

·
Registered
Joined
·
738 Posts
Do you mean center dash, right hand vent? There is no difference between the two, should be open behind there, its just a box duct. Could be something in there, rag, dead rat etc..
Like B2B says, got a flashlight? If your ducts are sealed you shouldn't be losing it anywhere
 
1 - 4 of 4 Posts
Top