Corvette Forum : DigitalCorvettes.com Corvette Forums banner

1 - 4 of 4 Posts

·
Banned
Joined
·
1,471 Posts
Discussion Starter #1
went out to check the charger 'cause the glove box was left open only to find that the charger had done nothing in the 5 hours it was on. as soon as the car got power the interior lights would come on and stay that way for about 25 seconds. and would fade out. charger still connected. everything was closed so no reason why the interior lights would come on, stick the key in the ignition to see if the rest of the car had power and it sounds like a electrical short (the electrical buzz) with the ignition in the on position, not the start position. so now the car is officially dead, unhooked the charger 'cause dont wanna take a chance of the car catchin on fire, nothin has power.. to the point with the car now that it seems like the only way to relieve the problems is to sell the damned thing..
 

·
Premium Member
Joined
·
6,667 Posts
Electrical gremlins suck! Calm down a bit, take a deep breath. Maybe the battery is unable to take a charge. Might try to swap w/a known "good" battery and see if that is the problem.
 

·
Banned
Joined
·
1,471 Posts
Discussion Starter #3
i dun think it's the battery, maybe i'm tryin to charge it wrong or somethin.. it's a Optima red top
 

·
Registered
Joined
·
113 Posts
There's an electrical post behind the battery where a bunch of cables join together and secured by a small bolt. I understand it is an electrical distribution center. By the location it has, it probably gets wet and dirty, so maybe the problem is one of corrosion. At least, in my '87 Coupe it is right behind the battery. There's not much to lose if you check those connections.
 
1 - 4 of 4 Posts
Top