Corvette Forum : DigitalCorvettes.com Corvette Forums banner

1 - 20 of 117 Posts

·
Registered
Joined
·
470 Posts
Discussion Starter #1
Now the car is back in belgium (click here for the story) I'm starting this thread about my needalota TLC vette

I had some issues getting it back from the port. When I started it for the 1st time in belgium fuel was spitting all over the engine.. a luck I had the hood open so I could turn the engine off before something bad happens.. dunno who played with my car but I had to tighten fuel filter hose clamp..

Then I realised the brake pedal was just pumping air.. so I didn't even dare to pass 'D'. Got it back on a flat bed, safer

I'll post some pics of her
 

·
Registered
Joined
·
470 Posts
Discussion Starter #2 (Edited)
Richie the seller in Willits, CA






In oakland hotel, before going to the port




In Oakland port before entering the container

 

·
Premium Member
Joined
·
10,260 Posts
good thing you caught the fuel leak when you did! Congrats on the new 'vette. I'm sure you'll have her looking and running well in no time :thumbsup:
 

·
Registered
Joined
·
470 Posts
Discussion Starter #9
My first objective is to get it legal here

So I need to fix the lights issues:

- lights don't pop.. though they did in USA. Maybe I need to drive it to repressure the system?

- turn signals don't work. Can't hear any relay switching.

- fix power windows

- buy new door locks.. seller lost keys :spanked:


Had to add some brake fluid. Now it's breaking but not as it should. There's some air in the system. I had the car on jacks, wheels removed but the drain plug broke when I loosened it (!) Should have it drink WD40 for a day before attempting this

When I had it on jacks I could see the suspension joints are in a really bad shape.
 

·
Registered
Joined
·
470 Posts
Discussion Starter #10
I built this to bleed my brakes:



Couldn't use it yet due to the broken drain plug on a front caliper but it is holding 30 PSI.. should be enough to bleed my brake system
 

·
Registered
Joined
·
470 Posts
Discussion Starter #11
Some pics of the interior before I throw all the junk




There was so many uninsulated wires under the carpet, now they won't mess again with the chassis ground




Dirtyyyy oily




What's this pull button for?




Can someone confirm the upper thing is for lights? What's the below thing?

 

·
Registered
Joined
·
1,497 Posts
The upper switch is for your windshield wipers the bottoms witch is your actual headlight switch that must be why they didnt come up;). if its like my car you need to replace them both to get them to function properly


Can someone confirm the upper thing is for lights? What's the below thing?

 

·
Registered
Joined
·
470 Posts
Discussion Starter #13
Right, 2 new things on the buylist

I started to dismantle my door panels. The left window motor is working but something is blocking or the window is not properly aligned cause it won't go up more than a few inches

The right motor doesn't respond at all

I'm amazed how many options were available in such an old car.. power window, cruise control, power seat.. those options appeared way later on European cars
 

·
Premium Member
Joined
·
6,667 Posts
What's this pull button for?

You pull that to keep the headlights up. Mainly used in the winter so the lights don't freeze shut.:cheers:
 

·
Registered
Joined
·
470 Posts
Discussion Starter #15
You pull that to keep the headlights up. Mainly used in the winter so the lights don't freeze shut.:cheers:
Good to know :thumbsup:
 

·
Registered
Joined
·
4,435 Posts

Hey Ben, Looks like you are really into the
wiring. I fixed some of the wiring problems with my 81. I 'll have to take the dash apart
to fix more of them.
Glad you got the car home okay and your trip went well. You had more of an adventure in the US than most people who live here. A lot of people never get out of their own state.
The car looked and sounded ok when you were
loading it on the flatbed.
Anyway, good luck with the project. Larry :thumbsup:
 

·
Registered
Joined
·
470 Posts
Discussion Starter #17

The car looked and sounded ok when you were
loading it on the flatbed. [/COLOR][/SIZE][/I]
Oh yeah it was running fine in the USA.. I think she didn't enjoy leaving his motherland :laughing:
 

·
Registered
Joined
·
470 Posts
Discussion Starter #19
I removed the door panels

What a mess inside the metal sheets



Is it possible to remove the inside part of the door to access the power window motors and guides? Something is blocking the front motor after a few teeth up or maybe the engine has become weak. The window goes up 4 inches then claps-claps-claps

Maybe broken teeth, gotta check tomorrow
 

·
Registered
Joined
·
470 Posts
Discussion Starter #20
I removed the window and put the camera into the door:



Half of the teeth are worn :(
 
1 - 20 of 117 Posts
Top