Corvette Forum : DigitalCorvettes.com Corvette Forums banner

1 - 7 of 7 Posts

·
Read Only
Joined
·
575 Posts
Discussion Starter #1
What's up guys! My buddy out in Phoenix has a problem with his auto shifter. He doesn't have any time to get on the internet to research so I told him the guys at DC might have an idea! He says it is extremely difficult to pull the automatic shifter out of park. He said sometimes he pulls on it so hard he thinks he is going to break something. It is also difficult to go from drive back into reverse or park. Does this sound like a common problem. Anyone have a fix for this issue. Also, once it is in drive the transmission runs just fine and it shifts good between gears. Is there a problem with the button on top of the shifter??? any ideas are welcome! Unfortunately I live 900 miles from him so I can't go check it out for myself, so lets see what we can come up with, with the information that was provided to me! THANKS!!
 

·
Premium Member
Joined
·
17,444 Posts
Which model does he have . It sounds like an adjustment on the park release button but it hard to say with out more info or being there.
 

·
Registered
Joined
·
34 Posts
Sounds familiar.

I have a 98 that gives me a little trouble once in a while.

I don't know the Vette specifically but in most cars there is a cable that runs from the brake pedal to the shifter. It makes sure that the brake is engaged before allowing you to shift from park (thank you audi lawsuits.)

Have your buddy push harder on the brake pedal and see if that is an improvement. If it improves, the interlock is out of adjustment.

Hope this helps.

Rad
 

·
Read Only
Joined
·
575 Posts
Discussion Starter #5
Hey guys. It's a 1998 coupe. It is just a stock automatic shifter. Nothing is done to the car at all. I'll tell him to push harder on the brake pedal to see if that improves the shifting. The car does have about 100K on the clock, but I have seen some Vette's on here with much higher mileage than that!
 

·
Registered
Joined
·
956 Posts
Sounds more like the brake interlock, but there is a possibility the shifter cable itself could be going or the actual shifter unit could be jammed. The cables GM used aren't much thicker than you standard 10 speed brake/shifter lines. I had to replace my shifter cable a while ago, so I've had the whole shifter out.

I really think you're going to have to take apart the console and play with the shifter to properly diagnose the problem.
 

·
Registered
Joined
·
635 Posts
I had the same issue with a 95 Corvette. I'm guessing the automatic shifter has not changed all that much. My problem was the shifter Celinoid. While pressing the brake to get out of park the shifter should unlock mine did sometimes but most of the time it would not. I got in contact with http://www.corvettesalvage.com/ and got a used shifter. Problem solved.
Hope this helps, good luck
 
1 - 7 of 7 Posts
Top