Corvette Forum : DigitalCorvettes.com Corvette Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
101 Posts
Discussion Starter · #1 ·
78 with AC..

ok i noticed my fan runs all the time even if my controls are OFF it sounds like its only on low...but its going none the less it still cycles up through the speeds when your useing it but the moment you turn the key it starts wirring.:thud:

is this a relay or bad speed switch ? and if its one of the relays where the heck is the most likely one...ive never replaced any of those things:crazy:
 

·
Registered
Joined
·
1,078 Posts
My 77' fan runs all the time (also with A/C). I can barely hear it. It does go threw the speeds too. I don't know if it is supposed to do that but owning the car 10 years and i have never had a problem. Hope this helps.
 

·
Registered
Joined
·
28 Posts
Pretty sure is started around '75 or so. The heater fan will always run on low even if the switch is in the off position. This is to create cabin pressure to keep fumes out of the car. I can not remember where I read :crazy: it but it makes sense.
c-ya
ToddG :cheers:
 

·
Registered
Joined
·
1,144 Posts
I read somewhere you can thank Ralph Nader for that some kind of safety thing.
 

·
Registered
Joined
·
2,948 Posts
:agree: The fan is always on. Was on my '77 until I pulled the system when I removed my A/C.
 

·
Registered
Joined
·
2,002 Posts
If you want to kill the automatic running of the fan, pull the brown wire out of the console switch connector.

:thumbsup:
 

·
Registered
Joined
·
101 Posts
Discussion Starter · #7 ·
Great thanks i think im gonna kill that thing ..recently put a new control assembly in it cause the old one was bad ...so i never knew about the full time run thing with the bad one .:D
 
1 - 7 of 7 Posts
Top