Corvette Forum : DigitalCorvettes.com Corvette Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Have a '99 C5 with about 20k miles on it. When I start it up and the fan or air kicks on, for about 15-30 seconds I get a foul odor coming out of the vents. Tried the usual. . .Lysol sprayed into the intake under the hood and also sprayed directly into vents. Also shut down A/C for 3-5 minutes and let fan run before turning off engine. Still same odor. It's kind of musty and moldy and almost "dead animal" smelling at times. But it does go away after 30 seconds or so. Any thoughts?
 

·
...twisting your mind and smashing your dreams.
Joined
·
9,389 Posts
Very common. Some get it, some don't, some more than others. It's just condensation build up in the ductwork/vents, most often in higher humidity climates. Groos for a few seconds, yes, worrisome, no:thumbsup:
 

·
Premium Member
Joined
·
17,444 Posts
I had a problem with the C5 AC design the water does not drain correctly and causes mold to grow in the duct. When mine was under warranty I would take it in once a year and have it cleaned out and sanitized. I'm not sure what all they did, all I know they were not happy to see it come in, must have been a dirty job. Maybe some one else has some input on this...
 

·
Registered
Joined
·
6 Posts
Discussion Starter #4
Thanks for the inputs. Sounds like a common problem. Will check the condensate drain. Does the C5 have a cabin air filter? Assume it does not, but not sure.
 
1 - 4 of 4 Posts
Top