Corvette Forum : DigitalCorvettes.com Corvette Forums banner
1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I have a 1999 C5 auto with approximately 60000 miles on it. Swapped out the shifter cable and bushings a couple of years ago. Worked great. However…. About a week ago the shifter started acting up. Each indicated gear position was one off. Swapped the whole shifter assembly for another one. Same problem. Must be in the trans itself , the cable bracket near the trans is intact and keeping the cable from moving back and forth as it should. Has anyone here ever had an internal trans shifter linkage problem ?
 

·
Premium Member
Joined
·
4,814 Posts
1997-2004 Corvette Automatic Shift Indicator Repair Kit With Lens And Pointer | Eckler's Corvette (ecklerscorvette.com)

Your problem is either the above link OR you did not set the adjustment right OR the lock on the adjuster for the cable came loose.

From underneath the rear of the vehicle on the driver's side on the shifter cable at the transmission is the adjuster. If it is not already unlatched, with the transmission in neutral you need to unlatch the shifter cable adjuster. With both the transmission in neutral and the shifter pointing at N you need to relatch the adjuster and things should line up just fine.

We always set shifter cable adjustments in neutral or at mid travel of the cable. Setting the cable adjustment in Park will cause this exact problem but it should have been like that from the time you installed the cable. Unless the adjuster came loose and that is identifiable by a sloppy loose shifter that still shifts r, n, and d but struggles to hit P or the low gears.
 
1 - 3 of 3 Posts
Top