Corvette Forum : DigitalCorvettes.com Corvette Forums banner

1 - 4 of 4 Posts

·
"a title"
Joined
·
790 Posts
Discussion Starter #1
Yesterday I had to remove the air filter unit to change out the serpentine belt in my C6Z. I started the car up and noticed that I forgot to connect the vacuum line on the side of the air bridge. I turned the car off and reconnected the vacuum line. Now today the car has a steady check engine light. How do you reset this light? I tried doing the c5 trick where you hold down the options button while hitting the fuel button 4 times. It doesn't work. I'm pretty sure this is what is causing the light to turn on. Yes, I checked to see if the gas cap was tight. Anyone?

Paul
 

·
Registered
Joined
·
307 Posts
You will have to run through the requisite number of ignition cycles before the CEL will clear itself - don't give it another thought . . . :partyon:
 

·
Registered
Joined
·
4,479 Posts
the check engine light is the stupidest idea ever
 

·
Registered
Joined
·
939 Posts
As stupid as this may sound, check to make sure the oil cap is tight. After replacing my fuel rail covers to match my body color, the dealership didn't twist it all the way tight and it came loose. I took it to another (closer) dealership to have my damn CEL checked and they just laughed at me after they ran the code and told me to check the car over before I start freaking out.

So, yeah, check the oil cap or anything else in the engine that might be loose :cheers:
 
1 - 4 of 4 Posts
Top