Corvette Forum : DigitalCorvettes.com Corvette Forums banner
1 - 8 of 8 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
85 C4

Cant get it to start.
I had a no crank no start situation initially until I jumped the Fuel pump interruption relay

Now crank and no start
It has a new fuel pump and filter
Fuel squirts out of the fuel fill line to the fluid pressure regulator strongly when disconnected.
When that line is plugged in however, fuel pressure at the schrader valve on the rail is 0
The crank is strong, battery is new

Is this still the VATS?
I thought that since it went from no crank to crank that i had bypassed this. Is this wrong?
Why is the fuel pressure still 0?
Is it the FPR?
Is it the rail?

Charles
 

·
Super Moderator
Joined
·
1,545 Posts
Maybe you could ask someone to opine?

C
Sorry, I don't have to ask others for opinions, you have posted your issue on a public forum for anyone who wishes to read. If there is a person that can make an attemp to diagnose your problem, they will chime in.

Trying to diagnose auto issues in writing is not like being there in person to inspect, view, hear, or observe what is going on, it's kind of like a hit or miss thing. What's the mechanic say when you call with a problem? "Bring it in!"

Hopefully someone may respond with some information to help.
 

·
Super Moderator
Joined
·
8,577 Posts
if you don't have fuel pressure in the fuel rail check the fuel pressure regulator




 
  • Like
Reactions: HN376RAR

·
Registered
Joined
·
1 Posts
When you first turn on key.... can you hear the pump for a couple seconds.... you may need someone to listen at rear of car. I just went nuts with an intermittent problem.... everything was good...pump,filter, regulator... It was the 3 prong connector between the outside wiring and internal wiring on the fuel tank assembly.... went through 3 good pumps.... there is more info on this blog some where... we're not the first
 

·
Super Moderator
Joined
·
8,577 Posts


 
  • Like
Reactions: HN376RAR
1 - 8 of 8 Posts
Top