Corvette Forum : DigitalCorvettes.com Corvette Forums banner

1 - 18 of 18 Posts

·
Registered
Joined
·
59 Posts
Discussion Starter · #1 ·
In my 02 Z06 last night I start the car turn on lights and my dash lights are very dim as if the battery was dyeing. About a half mile down the road they went out completely. All other interior and exterior lights work. Help please
 

·
Premium Member
Joined
·
30,448 Posts
Did you try checking the interior light dimmer switch?
 

·
Registered
Joined
·
59 Posts
Discussion Starter · #3 ·
I did and that's not it. It was already dim when I started the car and and continued to dim till it went completly dark. I read this about muti switch and of course your soldering fix so I want to get ideas before tearing into it.
 

·
Premium Member
Joined
·
30,448 Posts
I would try jiggling that switch before I would do anything. That switch is the most likely area for a problem to develop, unless some hack has worked on your car.
 

·
Registered
Joined
·
59 Posts
Discussion Starter · #5 ·
Thanks Junkman, Will do that and see if I can find something that may have come loose. The crazy thing to me is when you insert the key the cluster lights come on nice and bright the way they always have, when you turn your headlights on the cluster lights go off.
 

·
Registered
Joined
·
982 Posts
I would try jiggling that switch before I would do anything. That switch is the most likely area for a problem yo develop, unless some hack has worked on your car.
iif the other dashlights are still working the dimmer could be fine...there may how ever still be a second wire comming from the dimmer that feeds the cluster.....there is a power inverter ( i think ) that feeds the uv lights in the cluster, sounds like that may be the issue....but like junkman said first things first check the switch..... hopefully someone has a schematic they can post up for you
 

·
Registered
Joined
·
59 Posts
Discussion Starter · #7 ·
Its seems like it would be in that dimmer switch. If you can imagine the only light at night inside the car is the hud. No radio lights no nothing. You put the key in ignition everything lights up, you turn the lights on all console lights,radio lights everything go off. So all the lightbulbs work but all go off when you turn on the lights.
 

·
Premium Member
Joined
·
30,448 Posts
I can post a schematic if the OP knows how to read one.
 

·
Registered
Joined
·
59 Posts
Discussion Starter · #9 ·
Thanks Junkman, Post it just when you have time.
 

·
Registered
Joined
·
59 Posts
Discussion Starter · #10 ·
Just talked to a buddy that works parts at a Chevy dealer and he said it is the dimmer switch and needs replaced. 92.00 for the thing and he will bring it to me. Told me to take mine out and I can hook the new one up and make sure it takes care of my problem before I have to buy it.
 

·
Registered
Joined
·
59 Posts
Discussion Starter · #12 ·
Ok junkman' so it continues. I have had a switch on order for 3 weeks at the Chevy dealership. Still had not came in so I go to a different dealership and they tell me the switch is discontinued from GM. this is the part

http://www.zip-corvette.com/Product....+Switch&Referer=&Alias=&ptct=GL2-SR&CTitle=&

Would you have a schematic for something like that? I was just wondering if I could just bypass the switch for now or from now on. Its got my hud adjustments on that piece so I dont want to mess any of that up. I am still assuming that this is my problem.

Thanks
 

·
Registered
Joined
·
145 Posts
Have you tried contacting PartsTaxi? They are a forum vendor, try contacting them. I bought from them recently and they shipped pretty fast and had good prices. There's a slight possibility they have that switch in stock.
 

·
Premium Member
Joined
·
30,448 Posts
Have you tried contacting PartsTaxi? They are a forum vendor, try contacting them. I bought from them recently and they shipped pretty fast and had good prices. There's a slight possibility they have that switch in stock.
:agree:

Also, Corvette Recycling may have that part too. Here's your schematic. :thumbsup:
 

·
Registered
Joined
·
59 Posts
Discussion Starter · #15 ·
Thank you. Yes I have checked all the sites. Only one I could find was on Zip corvettes and they had none in stock. I will keep up the search.
 

·
Registered
Joined
·
59 Posts
Discussion Starter · #17 ·
Junkman today is my day off and I was determined to find out what was wrong with these lights. I do have a pod in the pillar with gauges for my supercharger. They got the power for the gauge lights from the dimmer switch. I unhooked the wire from the gauges and guess what my cluster came right on. That wire to the dimmer switch does not have enough juice for those gauge lights I assume. So I am about to put it all back together and I will need to find a different source to hook that wire to for my guage lights. Any quick ideas? Thanks!
 

·
Premium Member
Joined
·
30,448 Posts
Remember my comment about some hack working on your car? You are a victim.

I have never hooked up a cluster before so I don't know what the directions say to do. If you are just powering the lights to the cluster, my first guess would be to tap off the parking lamps. The only problem is that the C5 is a electrical headache when you start tapping into the wrong stuff (as you now know). Thus, if you have a stock headlight setup, try the parking lamps and see what happens. You don't want to do it all neat and then test it, just run a quick wire to the tap and turn on your lights. If it works, then you can figure out how to get the wire where it needs to go.

Do NOT splice into any wires with those splice connectors. Solder everything. That will eliminate connection issues that act flaky.
 
1 - 18 of 18 Posts
Top