Corvette Forum : DigitalCorvettes.com Corvette Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
When I installed my APS twin turbo kit on my 2005 C6 coupe, I had to remove the front suspension sensors for my F55 Magna Ride suspension. The air intake hoses needed to go where the sensors once were. So I replaced the F55 shocks with C6 Z06 shocks.

Now my DIC shows three error messages in succession. "Service Ride Control", "Shocks Inoperative", and "80MPH Maximum". They are pretty annoying.

Has anyone been able to successfully eliminate these crazy errors? :rolleyes:
 

·
Registered
Joined
·
9 Posts
Discussion Starter #3
I finally found a solution to my F55 problem, You can read my full install story and see the pics at the link below.

Click here for my install pics

Turns out that after wasting two hours Monday and another 2 hours on Wednesday at my local dealership, and having them tell me things like the servers were down and GM needed to write a program for my car. I finally today took it to a different dealer a little further away. My car was in and out in just a few minutes, and the messages are gone.

It looks like you definitely can disable the F55 option on a 2005 C6 using the Tech2 tool, you just have to find a technician who knows how to do it, and at a Chevy dealer, that can be challenging sometimes, but there are good Corvette techs out there.

Also, if you have HPTuners and ever get the message, you can edit the Speed Limiter2 setting in the PCM and set it to 186MPH like the speed limiter1 is set, and the DIC message changes to 158MPH max, so I wonder if that means it would go 158mph or 186mph... Hmmmm.....

Oh well, now it'll go 186mph for sure. :laughing:
 
1 - 3 of 3 Posts
Top