Corvette Forum : DigitalCorvettes.com Corvette Forums banner

1 - 11 of 11 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
i have a 07 c6 that at 5k miles, the fuel guage went to empty and the "service fuel system" message displayed on the DIC. just picked the car up from the service department at the dealership yesterday, and before i could make it to the freeway onramp, the guage dropped to empty again, and the service message reappeared.

i've asked the dealership numerous times if the fuel sending unit has been updated or not, as i remember this being an issue with 05-06 models, and that there was TSB for them. They told me that "these cars are alway built with the most updated revision of parts" and didnt bother to check the part numbers.

I've searched the forums here and at a few other places, and everyone who had the same problem said that late 06 there was to be a superceded part, but i couldnt find anyone that posted that they received the "new & updated" part. Was it ever released? Or are they going to keep putting in a part that is going to fail on me as soon as i drive off the lot?

I'm trying to keep a level head about this since the dealership/service department are not the ones build built the car or the fuel sending unit, they are just following the replacement procedures, but this is pretty frustrating that i buy a brand new car, and i'm already having repeat problems with it. I've had a bad taste of that with my sisters new mercedes benz that had gone to the dealership 8 times for a mysteious stall&die problem, that they couldnt figure out and had to lemon law the car for her.

-Ray

07 6M/3LT/Z51/NAV White/Red&Black 2 Tone
 

·
Registered
Joined
·
759 Posts
Damn! thats a new one to me. Our cars are almost identical, other than the nav.
I hope they get you squared away. does the car still run when the problem happens? does it drive the same?
 

·
Registered
Joined
·
6 Posts
Discussion Starter #4
Update:

Car is in the dealership service department a 3rd time for the same problem.

2nd time the problem occured was no more than 1 mile from the dealership after i took delivery for the first attempt to repair it.

3rd time occured in an more severe manner. At more than 1/2 tank of fuel the guage dropped to empty, and the message reappear followed by the sudden stop of the vehicle. It failed to restart after numerous tries. I was on a 2 hour journey back home on a highway with no shoulders, where i had to push the car a few miles to saftey so it would not block the freeway, and then procede to troubleshoot the car. the fuel pump was pumping but the engine was starved for fuel. i remember the fuel system having 2 fuel tanks, and took a wild guess that the transfer pump maybe went out. i figured that since the transfer pump does not have to be running, while i am refueling the car at a gas station, to fill both tanks.... i took a wild shot in the dark and decided to go find some fuel. Walked another 3 miles to a gas station to purchase a gas container and fuel, and returned to the car, and luckily got it to start to goto the gas station to complete "topping off" the tank that the fuel pump draws from. apparently the transfer pump's controlling computer randomly decided to go into a "transfer lockout" mode (as the dealer describes) and held ransom 1/2 a tank of fuel from the car itself. Why couldnt this of happened somewhere that had cell phone tower coverage under T-Mobile :huh:

Now i'm at the point of waiting for a field engineer to come to the dealership to diagnose the problem.

To date the car has approx 9.5k miles on it, since i took delivery in March.

Getting to the point of considering initiating a GM buy back request or a "lemon-lawing" the car.
 

·
Banned
Joined
·
334 Posts
Fuel F**ck -**

Update:

Car is in the dealership service department a 3rd time for the same problem.

2nd time the problem occured was no more than 1 mile from the dealership after i took delivery for the first attempt to repair it.

3rd time occured in an more severe manner. At more than 1/2 tank of fuel the guage dropped to empty, and the message reappear followed by the sudden stop of the vehicle. It failed to restart after numerous tries. I was on a 2 hour journey back home on a highway with no shoulders, where i had to push the car a few miles to saftey so it would not block the freeway, and then procede to troubleshoot the car. the fuel pump was pumping but the engine was starved for fuel. i remember the fuel system having 2 fuel tanks, and took a wild guess that the transfer pump maybe went out. i figured that since the transfer pump does not have to be running, while i am refueling the car at a gas station, to fill both tanks.... i took a wild shot in the dark and decided to go find some fuel. Walked another 3 miles to a gas station to purchase a gas container and fuel, and returned to the car, and luckily got it to start to goto the gas station to complete "topping off" the tank that the fuel pump draws from. apparently the transfer pump's controlling computer randomly decided to go into a "transfer lockout" mode (as the dealer describes) and held ransom 1/2 a tank of fuel from the car itself. Why couldnt this of happened somewhere that had cell phone tower coverage under T-Mobile :huh:

Now i'm at the point of waiting for a field engineer to come to the dealership to diagnose the problem.

To date the car has approx 9.5k miles on it, since i took delivery in March.

Getting to the point of considering initiating a GM buy back request or
a "lemon-lawing" the car.


SAME THING HAPPEND TO MY '05. IT'S EITHER THE SENSORWHICH MEANS ITS A BITCH TO TAKE THE TANKS(which is a bitch) OUT OR THE COMPUTER BOARD NEED THAT'S UNDER THERE SOMEWHERE SOMEWHERE HASN'T GOT ALOT OF COATING ON IT OR IT'S A SIMPLE SOFTWARE THAT THE TECH GUY GETS IT OFF OF THE INTERNET. HOPE THAT ITS THE LAST OF THE THREE.
THERE'S A BULLETIN ON THIS PROBLEM I'LL LOOK FOR THE NUMBER, i HAVE THE SHORT AND LONG ONE. it's a bitch. LOOK UP FUEL TANK, OR SENSOR OR GAUGE OR SOMETHING LOKE THAT.


'O8 GUY
 

·
Registered
Joined
·
6 Posts
Discussion Starter #6
Its already had the "fuel cards" (sensor/computer board) replace, and verified to have the updated software in the computer. With those problems that the other people have, the car still drives through the entire tank.

The dealer has already tried the remedies from the various TSB's out there.

Once i get close to 1/2 tank, the car runs out of gas and dies. Its not quite the same problem, like the others have mentioned on the forums.

Guess i'll find out when the GM engineer gets done looking at it.
 

·
Banned
Joined
·
334 Posts
TSB on Fuel

Its already had the "fuel cards" (sensor/computer board) replace, and verified to have the updated software in the computer. With those problems that the other people have, the car still drives through the entire tank.

The dealer has already tried the remedies from the various TSB's out there.

Once i get close to 1/2 tank, the car runs out of gas and dies. Its not quite the same problem, like the others have mentioned on the forums.

Guess i'll find out when the GM engineer gets done looking at it.

YOU NEVER KNOW SO HERE IS THE tsb for my '05

Part #: CVN DESCRIPTION: 1260574000002555 New software with diagnostic enhancements for DTC PO463 and P2068. GUESS YOU DON'T NEED THE REST
NOV. 18,2005

WHAT THE HECK. GOOD LUCK!

'08 GUY:spanked:
 

·
Registered
Joined
·
528 Posts
That blows man, good luck!!
 

·
Registered
Joined
·
6 Posts
Discussion Starter #9
** update **

Service manager called me this morning to give me a progress report,

they traced the fuel transfer lock out, to the BCM (body control modual) seeing a pressure loss in fuel system. they couldnt reproduce the pressure loss until they started to pull back and forth on on of the tubes connected to the tank. they pulled all the tubes that cross connect the tanks and inspected them and they are fine, and pulled the right tank to inspect where the tubes connect and it is fine/aligned correctly. apparently most of the lines and fuel system are plastic, that i didnt know. they are replacing every line in the system regardless if they seem fine or not. they are having them pulled from the assembly line at the factory, and put through the QC check (i guess GM ranbomly QC checks ever couple hundred to see if there are any production variations outside of the acceptable tolerences) before over nighting them to the dealership.

they know that they are in the approximate area of the problem, but not sure exactly what it is. atleast they are replacing all of the parts at once instead of throwing 1 part at a time at the problem.

so as it stands now, i just gotta wait for UPS to do their thing.

glad they are do what i asked of them, which was to fill me in on every technical detail of how they are troubleshooting and what steps they are taking, so i can put my mind at ease, and not treat me like someone "who only understands put gas and oil in the car and go"
 

·
Registered
Joined
·
77 Posts
:huh: I had the same thing happen to me a few months back. After taking the advice from a few members I have not had the issue since.

My Fix? I Disconnected the battery for a few minutes and no more codes. 5k miles late... I still have no codes or issues.

Good luck... You describe the same symptoms. I hope the $tealer is not just guessing and it's a simple computer recalibration.


http://www.digitalcorvettes.com/forums/showthread.php?t=76975
 

·
Registered
Joined
·
1 Posts
Fixed gas gauge

For what it's worth, my gas gauge went to empty and the dash said "Service Fuel System". At the same time, my windows quit operating correctly. Specifically, when I get out of the car and close the door, the window doesn't go up that quarter inch that it's supposed to. When my mechanic reprogrammed the windows, the gas gauge started working.
 
1 - 11 of 11 Posts
Top