Corvette Forum : DigitalCorvettes.com Corvette Forums banner

1 - 16 of 16 Posts

·
Registered
Joined
·
939 Posts
Discussion Starter #1
So for the past 500 miles of driving, there has been a nasty rattling under the driver's seat. I assumed it was something to do with the exhaust being too close to the heat shield because it was a metal on metal sound, but didn't sound too serious. I didn't get it taken care of right away because I figured it had something to do with the break-in period and that the problem would fix itself, but after 500 miles it got infuriating.:bang

Well, today I was driving my mama so she could get new tires on her Nissan Murano at the local Big O and while we were waiting I started talking to some of the workers about car stuff and mentioned that I had a nasty rattle in my car. They offered their lift and their expertise to try and solve the problem.

I rolled the Vette up on the lift and got under her, the problem was immediately visible (and I can't believe I missed it when I installed my Borla Stinger:spanked: ). The Stock Midpipe is completely misalligned, and there was a large hunk of tack-weld (like a metallic zit) on the side of the pipe that was scraping the heat shield.

So, to temporarily solve the problem, me and one of the workers at Big O pushed the midpipe toward the center with a pair of pry bars and a third guy got under there with an angle grinder and flattened out the hunk of weld.

The guys said I didn't owe them anything for the service and that they were just excited to have a chance to play with a Vette. I threw them each a $10 and thanked them for their help. Drove on home and the rattle was gone. Next week I'll have to go back to the dealership and get a more permanent solution to the missalligned mid-pipe.

Any other C6 owners had this issue?

Mike:thumbsup:
 

·
Registered
Joined
·
546 Posts
You thought it was part of the break in period???? hahahaha...sorry just made me laugh a little...but good thing it was such a small problem and cheap!
 

·
Only green will do...
Joined
·
18,388 Posts
Happy it wasnt something terrible good luck love the color
 

·
Registered
Joined
·
939 Posts
Discussion Starter #4
You thought it was part of the break in period???? hahahaha...sorry just made me laugh a little...but good thing it was such a small problem and cheap!
Yeah, I know...:rolling: wishful thinking, I felt pretty stupid too after I got her on the lift
 

·
Registered
Joined
·
939 Posts
Discussion Starter #5

·
Registered
Joined
·
161 Posts
No similar problem, just my leaking tranny. I took my stock midpipes off as fast as I could to get the headers and decent Kooks mid section in place. Highly recommend that mod; check my signature if you want more description. Glad you got 'er fixed and had fun doing it. Excellent form carrying the water for the Corvette community and tipping the techs-kudos.

From another AF aviator- push it up dude. Cheers.:cheers: :cheers: :cheers:
 

·
Registered
Joined
·
939 Posts
Discussion Starter #8

·
Registered
Joined
·
939 Posts
Discussion Starter #10
Alright, so not so big, but when you here metal clanging around underneath you in a brand new car you get a little freaked:nuts:
 

·
Registered
Joined
·
901 Posts
Before taking it back to the dealer, be absolutely certain it couldn't be related to the Borla installation. Otherwise they may decline to work on it under warranty, and may even have a minimum labor charge just for inspecting it (depends on the dealer).
 

·
Registered
Joined
·
125 Posts
I had exactly the same problem with my C6, but the rattle was under the passenger seat. I have a Corsa Sport Exhaust, and the dealer declined to do the work under warranty, or at all for that matter. You may have to take it to an outside shop for a permanent repair.
 

·
Registered
Joined
·
565 Posts
Before taking it back to the dealer, be absolutely certain it couldn't be related to the Borla installation. Otherwise they may decline to work on it under warranty, and may even have a minimum labor charge just for inspecting it (depends on the dealer).
Good point. It doesn't sound like it is in any way related, but dealers are funny about things. Plus, you did work on it yourself. Almost think if you solved the problem, skip the dealer. What else would they do? What would you want them to do? :lookinup:
 

·
Registered
Joined
·
939 Posts
Discussion Starter #14
Thats a good point, I just took it out for a 10 mile drive this morning to make sure everything sounded good, and the rattle is still gone, she runs fine. Think I'll just sweep this one under the rug:thumbsup:
 

·
Registered
Joined
·
8 Posts
I have had a similar rattle since new on my 07. Can't wait to check and see if it could be what yours was. There have been a lot of different components others have reported being loose from the factory like shock mounting bolts, sway bars, etc. Everything I could check so far has been fine (haven't got it on a lift yet though). Thanks so much. From you description mine could be something like that.
 

·
Registered
Joined
·
939 Posts
Discussion Starter #16
I have had a similar rattle since new on my 07. Can't wait to check and see if it could be what yours was. There have been a lot of different components others have reported being loose from the factory like shock mounting bolts, sway bars, etc. Everything I could check so far has been fine (haven't got it on a lift yet though). Thanks so much. From you description mine could be something like that.
Let us know when you get her up on the lift and give us a diagnosis. The excess tack weld on mine was right where the over the axle pipe and midpipe meet.
 
1 - 16 of 16 Posts
Top