Corvette Forum : DigitalCorvettes.com Corvette Forums banner

1 - 20 of 26 Posts

·
Registered
Joined
·
93 Posts
Discussion Starter #1
Finally got her all done...
Here is the finished product...(Sorry for you dial up guys....)





















I have the full build thread over at CF.....I just thought I would post the pics here and spare you all the grueling details...

3.36 Tom's Gears, 30 spline 12 bolt spiders, 12 bolt cross pin, Toms 30 spline side yokes, polished and blueprinted carrier..(Steel clutches). Full trailing arm rebuild with additional welding of all the seams, relocated e brake cable bracket, Toms 31 Spline outer spindles... Also got a new 2.5" x .095" walled driveshaft with solid spicers 1330 joints.

I'm still doing the break in heat cycles but the car feels noticeably "peppier" with the 3.36s vs. my old 3.08s. I hope to get it to the track in a few weeks after I get some miles on it.:D
 

·
Registered
Joined
·
93 Posts
Discussion Starter #2
BTW.... SPECIAL THANKS TO TRACDOGG2 (aka. Mike Dyers) for outstanding work and detail on my rear end/trailing arms....he helped me out a lot. GREAT WORK....I highly recommend him to anyone...especially the Texas boys.....

Ofcourse up north, use Gary Ramdei for great quality IRS work also...:cheers:
 

·
Registered
Joined
·
91 Posts
Alan-
That new rear end looks great! It must have went back together very smoothly judging by how quickly you got it done. Congratulations! Man it really makes want to get started on mine.

:cheers:
 

·
Registered
Joined
·
93 Posts
Discussion Starter #4
Alan-
That new rear end looks great! It must have went back together very smoothly judging by how quickly you got it done. Congratulations! Man it really makes want to get started on mine.

:cheers:
It took me 2 VERY SOLID days to get it in and running. I spent 12hrs on it saturday and 12hrs today.... I started at 6 am this morning and worked straight through (didnt even eat) I had it driving at 4:45p.... I still have to fine tune the alignment and diagnose a temp switch issue on my e fan but....all in all, the first drive went well...:thumbsup:
 

·
Registered
Joined
·
1,497 Posts
im in central texas and I would like this guys info, also some info on some pricing as well
 

·
Premium Member
Joined
·
10,260 Posts
great looking setup. Can't wait to see the slips :thumbsup:
 

·
Registered
Joined
·
2,948 Posts
Simply...awesome !!!

:thumbsup:
 

·
Registered
Joined
·
442 Posts
Great looking set-up. I love my Super 10.

Be sure to re-tighten all the axle bolts. I had mine up on the lift this Saturday and re-snugged all my bolts.

I bent the Tom's labels around a broom handle and stuck them to my 3" half shafts. After about 5,000 miles one is still on but the other has fallen off. Since I don't have the spare tire carrier in the way, my Corvette friends can see the label spin on the axle while I am driving.
 

·
Registered
Joined
·
4,607 Posts
Very cool!

Would you mind copying over some of your meatier posts from the other thread? Looks like you have some valuable knowledge in that setup.

BTW what color green is that? Do you have a full car shot?
 

·
Registered
Joined
·
93 Posts
Discussion Starter #10
Very cool!

Would you mind copying over some of your meatier posts from the other thread? Looks like you have some valuable knowledge in that setup.

BTW what color green is that? Do you have a full car shot?

Here is the full build thread...
http://forums.corvetteforum.com/c3-tech-performance/2665090-super-10-bolt-irs-build-up.html

Not sure of the color, the car was painted when I got it. I have had the color duplicated exactly though. Eventually I will repaint the car and I will paint it the exact same color...
 

·
Premium Member
Joined
·
17,444 Posts
Just curious why you did not go with a positrack? You beefed it up and then only put the power to one tire.
 

·
Registered
Joined
·
1,038 Posts
I believe it is still a posi... The clutches are preloaded with shims now, not springs
 

·
Supporting Vendor
Joined
·
3,776 Posts
That is correct, properly setup the posi will out perform a stock setup every time and not hammer.
 

·
Registered
Joined
·
93 Posts
Discussion Starter #17
I put a few heat cycles and light acceleration through it a few times yesterday and some more today.... I let it cool for a few hours then took it out again, this time I got it on the freeway and cracked the whip on it from a 60mph roll....
The rear end is dead quiet at all rpms, accel/decel....everything is smooth as glass.... I did notice that with the gear increase from the 3.08 to the 3.36, my automatic shift points are a little higher now.... the 1-2 is at 6000 and the 2-3 is at 6100......MAYBE a tad high but I am gonna run it like that and see what it does.... Also my rpms at 70mph only went up about 50-80rpms..... Now at 70 mph (on GPS) is dead on 3030rpms... before it was 2950.....That tells me my converter was slipping more then it need to when it had 3.08s...now it is more efficient. 3.36s drive nice around town, very responsive, picks up speed much easier with the same amount of throttle....freeway cruising is great...70-75mph no problem.... I LIKE IT....

Here is a couple pics from tonight, I gave her a quick bath to get the month worth of dust off. I have a few more tweaks to make but I will be driving this piss out of this thing this weekend...





:thumbsup:
 

·
Registered
Joined
·
93 Posts
Discussion Starter #19
Next go for a 5 speed. I broke lots of nice auto trannies until I got smart.

Lol...you can't be serious George...? A 5spd? Unless it's a G Force, Tranzilla, Liberty or Jerico, I would break a regular Tremec style 5spd in one night at the track....there is a reason 90% of drag, street/strip cars run autos....they're quicker and break less...I will take my chances with my T400...:smack
 

·
Registered
Joined
·
4,607 Posts
I put a few heat cycles and light acceleration through it a few times yesterday and some more today.... I let it cool for a few hours then took it out again, this time I got it on the freeway and cracked the whip on it from a 60mph roll....
The rear end is dead quiet at all rpms, accel/decel....everything is smooth as glass.... I did notice that with the gear increase from the 3.08 to the 3.36, my automatic shift points are a little higher now.... the 1-2 is at 6000 and the 2-3 is at 6100......MAYBE a tad high but I am gonna run it like that and see what it does.... Also my rpms at 70mph only went up about 50-80rpms..... Now at 70 mph (on GPS) is dead on 3030rpms... before it was 2950.....That tells me my converter was slipping more then it need to when it had 3.08s...now it is more efficient. 3.36s drive nice around town, very responsive, picks up speed much easier with the same amount of throttle....freeway cruising is great...70-75mph no problem.... I LIKE IT....

Here is a couple pics from tonight, I gave her a quick bath to get the month worth of dust off. I have a few more tweaks to make but I will be driving this piss out of this thing this weekend...





:thumbsup:
You need to find me that paint name and brand! :laughing: That is exactly the shade and metallic I want. Looks killer. :devil:
 
1 - 20 of 26 Posts
Top