Corvette Forum : DigitalCorvettes.com Corvette Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1


When troubleshooting our 52mph "sputter" problem we found this loose connector under the air box. Should it be connected to something?


Thanx in advance...
m
 

·
DC Crew
Joined
·
3,723 Posts
Yeah, that's for the fetzer valve. Some 30 weight oil and some gauze pads should fix you right up. (sorry. Fletch references should be applied whenever possible.)


questions: does your right headlight open?
do both your horns work?
 

·
DC Crew
Joined
·
32,974 Posts
Thanks Bkuper I couldn't come up with anything witty to say.

Xbroker I'll look at my car tomorrow and see if I can shed some light on that
 

·
DC Crew
Joined
·
53,221 Posts
Isn't that the connector for the right under hood light? Looks like the harness has been seperated to keep the light from coming on. There should be another end, if you follow the wire from the right under-hood light all the way down.
 

·
Premium Member
Joined
·
11,627 Posts
It looks like the connector for the under hood lights. :)
 

·
Registered
Joined
·
6 Posts
Discussion Starter #7
2 Horns????

All my lights work, I don't think I have an outside temp display (manual ac) My horn even works but does sound kinda "wimpy":)

Are there really two horns that connect separately or are you pullin this newbie's leg???

I thought maybe it was for an "engine block heater" needed in cold climates. cause it doesn't appear to EVER been connected to anything, (no wear on it at all)

m
 

·
Registered
Joined
·
9 Posts
where's the bowlingreen name plate? that plug may be for the outside temp sensor , whichs seems not to exists.. it usually is installed with electronic climate controls...:surprised
 

·
El Teafive
Joined
·
10,489 Posts
Re: 2 Horns????

xbroker said:
All my lights work, I don't think I have an outside temp display (manual ac) My horn even works but does sound kinda "wimpy":)

Are there really two horns that connect separately or are you pullin this newbie's leg???

I thought maybe it was for an "engine block heater" needed in cold climates. cause it doesn't appear to EVER been connected to anything, (no wear on it at all)

m
More then likely for the C68 Electronic AC.. cheaper to have one harness then 2 different ones..

That connector is part of the forward body harness
 
1 - 9 of 9 Posts
Top