Corvette Forum : DigitalCorvettes.com Corvette Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Okay, so i went out to my car this morning and turned it on and tried to put it in reverse but the button on the shifter wouldnt budge... Now this has happened before but i have always at some point gotten it unstuck, but this time it just wont budge. Do you all have any suggestions...?
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
Welcome bluufire! :cheers:

If you didn't know, the button can be popped off. Once off, you can inspect for damage or see if the spring clip was binding. Let us know what you find.
Thanks!
No i did not know that... I just bought the car about 2 weeks ago so Im still just a newb... I will try and pop that off tomorrow and see what i can find.
 

·
Registered
Joined
·
74 Posts
It sounds as if it may be a problem with the stupid brake interlock that prevents you from putting it in gear w/o your foot on the brake. You'll probably have to pull the cover plate over the shifter. When you do unhook the cable for this and leave it unhooked or better yet remove completely it and put it in the sh!tcan where it belongs. It's just more idiotic, worthless government-mandated crap to protect us from ourselves.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #7
So you can unhook it and it will still work? I checked the button and everything seems to be fine... I believe it is that cable that is keeping me from shifting out of park... I may see if i can fix very easily and if not I may try that...

My next question is...how do i get the cover off from around the shifter?
 

·
Registered
Joined
·
1 Posts
Can't get my 1995 C4 out of park either.

I have a 1995 with the same problem. I cannot depress the button on the top of the shifter to get it out of park. The problem is worst in the morning when I first start it up. The rest of the day is fine. What and how do I remove parts to get to where I need to be to fix this problem? Yes, I have the break depressed.
Yes, I've tried all the possible ignition switch positions.
I bought the car new in 95. This problem started some months ago and has been getting worse.
 
1 - 8 of 8 Posts
Top