Corvette Forum : DigitalCorvettes.com Corvette Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I followed the posts to wire back the locking prong on my C6 automatic and it worked as promised to allow me to move the shifter lever. Problem now is that when I shut off the engine the "shift to Park" message appears in my display and when I open the door the radio and other accessories stay on and drain the battery.
What can I do to shut off the accessories after shutting off the engine and opening the door?
I can live with display but not with this battery draining complication.
Thanks in advance for you help
 

·
DC PIT CREW BOSS
Joined
·
36,360 Posts
You will probably need to hook it up to a Tech II to get the code that are displayed
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Problem Solved!

Turns out that my wiring used to hold back the pawl interfered with the shift lever moving far enough forward to close the micro switch for the "park" function leaving it open and consequently not sending the signal to the system to shut off accessories when the door opened.
Went back in, got rid of my offending wire solution, and just used wire cutters to cut off the tip of the pawl so it couldn't lock up again.It worked!!!
Beats the sh** out of having to buy a whole new unit with no real assurance that the problem would not occur again.
Thanks to all the contributing members for their super-helpful posts addressing this problem.
 

·
DC PIT CREW BOSS
Joined
·
36,360 Posts
Sometimes it is a long process to get to an easy fix:thumbsup:
 
1 - 4 of 4 Posts
Top