Corvette Forum : DigitalCorvettes.com Corvette Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
44 Posts
Discussion Starter #1
hey C3 people :p
i just got me a 79
pic===> (( http://www.digitalcorvettes.com/photopost/showphoto.php?photo=5534&password=&sort=2&cat=525&page=1 ))

got a holley 650 carb, flowmaster, i think CAM maybe cuz it really sounds BAAAD.. this car was dragraced.. so no A/C compressor.. 3/4 of the guages dont work.. ! and nothing is original i guess.. i bought it for 1800$ i think it was fair.. its my project car so nothing fancy for now..
just liked to share the info :p of what i dunno hehehehe
oh i just painted the C4 in the pic ;) and noo it aint like the GrandSport stripes .. :surprised
ok now for the problemo hehe
my windows wont go up.. and sometimes wont move.. so i'm thinkin its stuck or dirty ? any1 got another idea ? it was left in a field for about 1 and half years.. !
and what about the guages ? do i need wiring or what to make them work.. the clock .. pressure gauge.. engine heat.. and RPM .. non of them work ..
hmmm the other stuff i'll need TIME to do .. like i said PROJECT car hehe :thumbsup:
 

·
Registered
Joined
·
281 Posts
I'm no expert, but the first thing I'd do for the guages is see if they're all plugged up. The tach will probably go to the distributor, the heat guage probably to one of the heads, the oil pressure to the driver side above the oil filter. The clock will probably have to be rebuilt (send it off or get a do-it-yourself kit) but first maybe check to see if it is plugged up as well. Since the car was drag raced, I'd dare to say that at one time it had aftermarket guages, so all the stock ones were probably just unplugged, or the sending units were removed and plugged. Did that help? I know thats sort of an obvious answer, but the obvious ones are usually the ones I always miss....:stick:
 

·
DC Crew
Joined
·
32,974 Posts
Congrats on the car. I agree with gunner if the car was raced the guy might have had all of that unkooked. Good luck and keep us posted.:thumbsup:
 

·
Registered
Joined
·
2,409 Posts
:buhbye: :thumbsup:

just rip out the old gauges and install Autometers. It's cheaper and much better.
 

·
Registered
Joined
·
281 Posts
Sounds good to me. Is that a difficult undertaking? Is there any particular ones that suit this application well? Are there tach's and speedos to match???
 

·
Registered
Joined
·
2,409 Posts
Gunnersix6 said:
Sounds good to me. Is that a difficult undertaking? Is there any particular ones that suit this application well? Are there tach's and speedos to match???
The Autometers?

Not difficult at all. Yes, they have matching tachs and speedo's. Get the 2 1/16 gauges. A Summit catalog lists most of them. Check this out. http://autometer.com/
 

·
Registered
Joined
·
44 Posts
Discussion Starter #11
hmmmm . i was thinking of the auto meter stuff.. but i think if the original ones work that would be hotter ;) i like stock looks in the interior.. but on the outside thats another story hehehehe
anyways thnx for the hi's and hello's and i'll keep posting ;)
 

·
Registered
Joined
·
44 Posts
Discussion Starter #12
ok so i opened up the plastic infront of the RPM gauge.. the little dial thing was all the way at to the right on like 8000.. i think..
i flipped it back to 0 rpm.. and started the car.. it wouldnt move.. but when i moved it to around 3000 it just moved all the way back to 8000 :S .. whats wrong
 
1 - 12 of 12 Posts
Top