Corvette Forum : DigitalCorvettes.com Corvette Forums banner

1 - 16 of 16 Posts

·
Registered
Joined
·
113 Posts
Discussion Starter #1
I am gathering pics and ideas for my interior so I am looking for pics of stock and custom interiors. I bought a pair of c-4 seats and was going to recover them but prices are a ton of money so I have decided to go the fiero seat route and get Mr Mikes covers instead. If I can come up with something fun, I wanted to do custom logos on the seats, door panels, and maybe the dash. My license plates have "WICKD" on them and I wanted to incorporate that plus some kind of a simple logo with it. My car is a twin turbo big block that will be riding on c-4 suspension and 18" wheels, it truly is wickd. I love the look of this interior but mine will be red and grey or silver. Anyways if you have any pics to share...

Mike
 

Attachments

·
Registered
Joined
·
113 Posts
Discussion Starter #2
I found this logo, I like the top outline with room to write under it. A vette outline would look good done this way, what do you guys think?
 

Attachments

·
Registered
Joined
·
4,075 Posts
I am gathering pics and ideas for my interior so I am looking for pics of stock and custom interiors. I bought a pair of c-4 seats and was going to recover them but prices are a ton of money so I have decided to go the fiero seat route and get Mr Mikes covers instead. If I can come up with something fun, I wanted to do custom logos on the seats, door panels, and maybe the dash. My license plates have "WICKD" on them and I wanted to incorporate that plus some kind of a simple logo with it. My car is a twin turbo big block that will be riding on c-4 suspension and 18" wheels, it truly is wickd. I love the look of this interior but mine will be red and grey or silver. Anyways if you have any pics to share...

Mike
How much cheaper is the Fiero seat option?

Good license plate for a twin turbo big block!
 

·
Registered
Joined
·
113 Posts
Discussion Starter #4
It seems like 800-1,000 bucks for seat covers for c-4's and the Mr Mike seat covers are around half that and he will do custom embroidery Here is my first attempt at making a logo, messing around in paint. trying to come up with something that represents the vette, wickd, and turbos. Please be gentle on me, not much of an artist.
 

Attachments

·
Registered
Joined
·
366 Posts
All of your picture links seem to be broken.

:cheers:

Rick B.
 

·
Registered
Joined
·
113 Posts
Discussion Starter #6
Thats wierd, they all show up on my computer.
 

·
Premium Member
Joined
·
4,668 Posts
I cn't see the pics either. I get a box with a red X in the corner. It's not a pop up blocker so what could it be. Only happens sometimes.
 

·
Premium Member
Joined
·
30,448 Posts
I cn't see the pics either. I get a box with a red X in the corner. It's not a pop up blocker so what could it be. Only happens sometimes.
Make sure that you are using the latest version of your web browser. Also, empty your browser history. Another thing that I would suggest is using a different web browser like Mozilla Firefox.
 

·
Registered
Joined
·
366 Posts
Make sure that you are using the latest version of your web browser. Also, empty your browser history. Another thing that I would suggest is using a different web browser like Mozilla Firefox.
I don't want to beat a dead horse, but I did a quick survey of all of the threads on page 1 and this poster's pics are the only ones that don't display in my browser. Leads me to believe that the problem lies in the way that he is posting the pics rather than in the way that people are viewing them. I am using IE8 and I'm not going to install another browser just to read a couple of threads.

:cheers:

Rick B.
 

·
Premium Member
Joined
·
30,448 Posts
I don't want to beat a dead horse, but I did a quick survey of all of the threads on page 1 and this poster's pics are the only ones that don't display in my browser. Leads me to believe that the problem lies in the way that he is posting the pics rather than in the way that people are viewing them. I am using IE8 and I'm not going to install another browser just to read a couple of threads.

:cheers:

Rick B.
Okay, here's what I did. I opened this thread in 3 different browsers:

Internet Explorer 6.0.3790.3959 (a very old version of IE)
Mozilla Firefox 3.6.9 (my default browser)
Google Chrome 8.0.552.224 (a old version of Chrome)

In all 3 browsers, all of the pictures show up so the problem is definitely is not the OP's end. Again, I suggest you clear all of your browser's history. That may remedy the problem.
 

·
Registered
Joined
·
113 Posts
Discussion Starter #13
I use firefox for a browser. I just have pics saved onmy computer and upload them on here. Funny thing though, on my work computer also using firefox, the past several weeks I cant see most pics on posts. I will try cleaning out the history and see if that works on it.
 

·
Premium Member
Joined
·
30,448 Posts
I use firefox for a browser. I just have pics saved onmy computer and upload them on here. Funny thing though, on my work computer also using firefox, the past several weeks I cant see most pics on posts. I will try cleaning out the history and see if that works on it.
Use a utility like CCleaner (it's free, no matter what you think you're seeing). It will not only clear your browser's history but will clean up all the other garbage left on your hard drive.
 

·
Registered
Joined
·
237 Posts
Use a utility like CCleaner (it's free, no matter what you think you're seeing). It will not only clear your browser's history but will clean up all the other garbage left on your hard drive.

x2


I also tested with IE7, IE8, FF and they load fine.
 
1 - 16 of 16 Posts
Top