Corvette Forum : DigitalCorvettes.com Corvette Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
477 Posts
Discussion Starter #1
Hey guys havent been around in a while (kinda Had to calm down with the MOd bug lol)

but i couldnt think of a better place to come to Ask for help Before spending Alot Of money on repairs.

I have a c5 97. the car has never giving me Problems... outside the random Colume lock and the Empty Fual gage.

I am now in nj and Hadnt used the car for about 6 months almost.

Now This weird thing has been happen.

First thing is this Raddle Crackling sound that the car is making under light and heavy accleration.

i first started to hear it when I had the Car in OD and Would lightly Get on the gas ..

I started to think that it was my o2 simulator rattling up against something .. but now its turned into A crackling noise under full throttle.

Also Last night me and a friend were going for a drive and we decided to See if the car would spin them off the line.. it never really has being that it has 2:73 in the rear..

But the thing is when I floor it Off the line .. traction control on or off ...

it makes a clunk Sound and then takes off ... but no spinning and also Kinda slow For a vette... I remember this car having more power .

also I have noticed that when not at full throttle Sometimes it will be picking up speed and seems like it Loses power and then Picks it up again ..

I really relate this to a throttle body that I bought . it was teh last mod i did and since then the Car just hasnt felt hte same.

It was from a M6 z06 and had been Ported I guess...

Could this be a Intake Problem ?

I reset the octane tables .. and still samething ..

the crackling rattle Noise is def getting louder ... and the car just doesnt have the punch anymore ..

any help would be great before I get raped for repairs

thank you so much in advance
 

·
Registered
Joined
·
3,963 Posts
Is the crackling noise coming from the engine or the exhaust?Whats the mileage on your '97 ? any check engine lights ? Have you checked the car for any codes ?
 

·
Registered
Joined
·
477 Posts
Discussion Starter #3
sounds like its coming from the bottom of the engine.

there havent been any codes.

i have about 42k miles on the car right now.
 

·
Registered
Joined
·
3,963 Posts
Re you running original cats ?
 

·
Registered
Joined
·
3,963 Posts
02 sim could be bad,maybe sending false signal to the PCM
 
1 - 7 of 7 Posts
Top