Corvette Forum : DigitalCorvettes.com Corvette Forums banner
1 - 6 of 6 Posts

·
Registered
Joined
·
147 Posts
Discussion Starter · #1 ·
My 6 speed '02 Z06 with 53K on it just started making a knocking sound at idle, apparently from the rear of the engine. Guess it could be anything from the flywheel to the clutch to the driveshaft attachment. Sounds expensive in any case. The car runs fine however - no shaking, the clutch is smooth as silk and no other funny noises.

It is only noticeable at idle and at that speed, it seems to be a metallic knock type of sound. When I first noticed it seemed to be coming from the rear end (thinking it was a transmission issue) but on closer inspection, it is originating at the engine.. And it makes the sound whether the clutch is in or out. So I suppose that eliminates the drive shaft! Interestly, you can't hear it from the topside even with the hood open. Get down to the ground and there's no missing it.

I am not a big believer in extended warranties - they've saved my bacon before and I've thrown away money other times. Sounds like this time it may pay off:laughing:

Anyway, it's at the Dealer (what do I care about cost?) and I'll be curious to see what they find. I'll share that info as it may help someone else!
 

·
Registered
Joined
·
345 Posts
What, no trouble codes? I thought those computers would pick up on something like that.
 

·
Registered
Joined
·
147 Posts
Discussion Starter · #3 ·
What, no trouble codes? I thought those computers would pick up on something like that.
Nope, no codes from that. Then again, I suppose not everything is monitored by the computer.
 

·
Registered
Joined
·
147 Posts
Discussion Starter · #4 ·
Nope, no codes from that. Then again, I suppose not everything is monitored by the computer.
Well, the Dealer just called and said the computer finally threw a code. Turns out one of the cats has a broken catalytic media inside. To me, this explains why the noise appeared to come from the rear of the vehicle at first.

Since the cat is part of the emission control package (and the factory warranty is 8 years/80K miles for emission controls), this is a no charge repair.

Whew!
 

·
Premium Member
Joined
·
6,667 Posts
:thumbsup:
 

·
Registered
Joined
·
28 Posts
:thumbsup: I had the same thing happen to mine awhile back. I was like you thinking the worst, started pricing engines etc. Glad I figured it out before I spent alot of money. :thumbsup:
 
1 - 6 of 6 Posts
Top