Corvette Forum : DigitalCorvettes.com Corvette Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
402 Posts
Discussion Starter #1
Well I took the vette out this morning and the car felt fine a drove well, Beautiful day to take the top off and go cruising... Well I pulled it out this evening to wash it and I go to wash the right rear and realize that isnt brake dust thats all over the place... thats ****ing grease!! Not sure yet whether its a cv boot or a wheel bearing or hell knowing my luck it could be both...Little background on the right rear suspension.. about a year ago I let my cousin drive the car and he turned the TC off lit up the rear tires and spun us right into a curb... right rear suspension was pretty much entirely replaced... so if its a wheel bearing im thinking it may also be that its a crappy upright too... Here's some pics.... any advice is more than appreciated...




 

·
Registered
Joined
·
169 Posts
That appears to be CV joint grease.

Replace the whole assembly for a few $ more than just the joint and boot.
 

·
Registered
Joined
·
402 Posts
Discussion Starter #3
Yeah, thats what I was thinking too... I have no idea how long it's been losing grease, so it couldve gone through a few heat cycles... Thanks. :cheers:
 

·
Registered
Joined
·
12 Posts
It's not like you have been driving it around in the elements like that for a year. Just buy a new boot and pack it with grease...no need replacing the whole thing. I could see if it was making noise, but the grease is clean, it will be fine with a new boot and grease.:buhbye:
 
1 - 4 of 4 Posts
Top