Corvette Forum : DigitalCorvettes.com Corvette Forums banner
1 - 15 of 15 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
New to the C4 had it since May. Already put a new Opti-spark in. Now it starts to just shut down when driving and then restarted. Put in new fuel pump. Nothing changed. Need to change the fuel filter yet, did replace O2 sensors and the ICM in May. Now it will not start at all. Codes 31 32 33 34 35 36 37 38. not sure how that is even possible!! don't want to just keep buyinh new parts and hoping for the best. Any and all advice is appreciated. Love the car and have no desire to give up on it. Thank you for any help you can give,
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #4 ·
Guess I carried away finding a site that is legit and forgot topost the year. I have 1994 C4. Disconnecte dth ebattery for afew hours today. Started righ up, sat and idled for 5 minutes but a little rough then just shut right off and would not start again. Iknow if I repeat the process it will start right back up again.
 

·
Super Moderator
Joined
·
2,009 Posts
Guess I carried away finding a site that is legit and forgot topost the year. I have 1994 C4. Disconnecte dth ebattery for afew hours today. Started righ up, sat and idled for 5 minutes but a little rough then just shut right off and would not start again. Iknow if I repeat the process it will start right back up again.
Any water in the fuel tank?
 

·
Registered
1996 Collector's Edition
Joined
·
8 Posts
Did you research and study the codes that you pulled from the PCM?? In my experience, the codes are important because they inform you about what the PCM is complaining about. They are usually good hints that you can use to narrow down your problem. If you have the information on each code, please post them here so that we can look at them too.
 

·
Registered
1996 Collector's Edition
Joined
·
8 Posts
I found a listing of the codes you mentioned except for #31. I agree they don't make sense.
Handwriting Font Circle Writing Number

I'm not familiar with a 94 C4, but I would want to make sure that the ground that connects this car's computer to the frame are all clean and tight.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #9 ·
I notice (when it runs) as i ran the rpm's up that when it dropped down and went past 1000 the dash light seem to blink once. I am going to track down th egrounds and see if that works. Thank you for the input. I will let you know the results. .
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #11 ·
I have ruled just about everything out and am afraid I have another bad Opti-spark. I just replace dit about 3, 000 miles ago with an Accel unit. i had someone turn it over as I checked for spark and have nothing. I haveGoing with my gut and thinking Opti-Spark.
 

·
Registered
1996 Collector's Edition
Joined
·
8 Posts
Just to be absolutely sure about detecting the spark on my '96, I ran a ground wire with spring clamps on both ends from the spark plug body to the negative battery terminal. I even had my wife record a video of the spark while I cranked the engine. I'm a bit anal about having good grounds when working with Corvettes.
 

·
Registered
Joined
·
2 Posts
I am casing a sometimes doesn't start in a 95. i am waiting for the next time and am going to try eliminating the possibility of an injector that shorts when it gets hot. If you have a solid no start check the resistance of each injector see if any are shorted, Cold mine vary by 2 ohms but I hav not checked them hot and no start.
I have changed the opti-spark twice with NEW ones, coils several times, the module several times. When I got the car 10 years ago it was a slug I discovered that the cyl 5 and 7 injector wires were swapped. when I corrected that it came to life. The 95 convertible does not get driven much because there are 3 other Corvettes that I prefer,
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #15 ·
So my journey continuies. But not giving up as I love the car. i have replaced, fuel pump, opti-spark, iCM, needed a battery anyway, O2 sensors are new. I really though opt-spark was it. Replaced it and it started right up and shut down in a minute. Thinking it is a fuel problem. still need to change the fuel strainer a new one didn't come with my fuel pump and th efuel filter which is sitting on th e bench. A little frustrating at times but I will perciver . Any help or insight is appreciated.
 
1 - 15 of 15 Posts
Top