Corvette Forum : DigitalCorvettes.com Corvette Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
81 Posts
Discussion Starter #1


The only problem is that it defaults to k/m when i start the car up. And i have to change it to mph. Does anyone know how to default it back to mph?
 

·
Registered
Joined
·
2,151 Posts
RED X
the dealer might be able to change the country code in the cluster IF U.S. is listed in that cluster
 

·
Banned
Joined
·
591 Posts
will your car EVER go anywhere near that 300 ?:huh:
 

·
Registered
Joined
·
6,158 Posts
Are you pushing the E/M key on the DIC to get it back to mpg?

Maybe try setting the Language. On the DIC press the OPTIONS button until the work LANGUAGES appears on the display. Use the RESET button to page throught the following choices:
LANGUAGE ENGLISH
LANGUAGE FRENCH
LANGUAGE GERMAN
LANGUAGE SPANISH0
 

·
Registered
Joined
·
81 Posts
Discussion Starter #7
ragvette said:
Are you pushing the E/M key on the DIC to get it back to mpg?
Yup, im pushing the e/m key to get it back.> It keeps going back to km when i use the car again. Its set on english mode to. There has to be away to default it back somehow.
 

·
Registered
Joined
·
78 Posts
300 MPH CLUSTER

The 300 mph clustster is only made for canadian chevrolet products. That is why it reads 300 mph because they use a matric or K/M speed limit.

Since that is a canadian cluster it automaticly has a k/m default setting programmed in to it that's why it keeps switching back every time you shut the car off.

Unfortuniatly your stuck with it there is no switching it back as far as I know.

I have a friend with the same cluster and he has the same annoying problem with his.
 
1 - 9 of 9 Posts
Top