Corvette Forum : DigitalCorvettes.com Corvette Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I was wondering if anyone else has had the same problems I'm having with my gas gauge giving false readings.
It seem's to stick at a litltle over a half a tank, then not release unitl it's empty.
Any suggestions?
Thanks
Flash-um
 

·
Premium Member
Joined
·
17,444 Posts
Have you always used the same gas? I would say thats the only common thing between the cars...:huh:
 

·
Registered
Joined
·
956 Posts
From what I've read, its a fairly common problem C5's. I haven't had that problem so I haven't paid much attention to the posts, but I believe most people claim it has to do with sulfur in the gas dirtying the fuel sensor. These Vette's have two interconnected tanks, so it sounds like only one of your sensor is acting up. Most people try running a can of techron fuel system cleaner. You may also want to consider trying a different gas station.
 

·
Only green will do...
Joined
·
18,388 Posts
Its happens to me all the time on my 95 voyager i just add when it gets to the middle of the gauge/1.2
 

·
Registered
Joined
·
123 Posts
I have the same problem in my S-10 but not my vette...

Many years ago I found out the hard way that my gas gauge was way off...

The gauge in my S-10 was just below 1/4 and it just died on... Mind you I was in the middle of the Ocala forest with nothing for miles... I got some good excerise in that day! :)

Hey, welcome to the boards from a neighbor in Panama City! :partyon:

~Jonathan
 

·
Registered
Joined
·
18 Posts
Go get a bottle of Techron at Autozone.; and if it's available stick with Chevron gas. It's got techron in it.:thumbsup:
I used to have that trouble all the time untill I put that in.
The first time mine did it I bought a bottle (20 gal size)then filled it with gas and the problem was gone by the time I got home!
Also go ahead and google "Top Tier Gasolines" It explains it.:cheers:
 

·
Registered
Joined
·
133 Posts
Melt Down

Go get a bottle of Techron at Autozone.; and if it's available stick with Chevron gas. It's got techron in it.:thumbsup:
I used to have that trouble all the time untill I put that in.
The first time mine did it I bought a bottle (20 gal size)then filled it with gas and the problem was gone by the time I got home!
Also go ahead and google "Top Tier Gasolines" It explains it.:cheers:
Careful; using 20 Gal may melt down the engine.:rolling:
V8GRA:buhbye:
 
1 - 8 of 8 Posts
Top