Corvette Forum : DigitalCorvettes.com Corvette Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
92 Posts
Discussion Starter #1
so i have a 1 hour commute from school to home. The past 3 weekends ive been running back home to prepare stuff for grad school. Heres the dillema i keep getting the CEL but only on my way back to school (The car has never done it on the way home) When i turn the car off, the CEL does not come back on, even when driving around school. It has only come on when im on my way back from home to school. I park the car for the night, get back in it the next day and its off. I have scanned the car after each time it comes on, im getting code 12 (diagnostics functioning properly or w.e.) Any idea as to what can be causing this? Its got me stumped, the car will run totally fine with the light and the MPG is consisten. If anyone has a clue please let me know
 

·
Registered
Joined
·
1,855 Posts
i keep getting the CEL but only on my way back to school
Maybe the car doesn't like going to school?

I have had similar and put it down to the ECM seeing something it didn't like but it not happening frequently or long enough for it to record it
 

·
Registered
Joined
·
111 Posts
I get a ses light when driving at hiway speeds, but only if the outside temp is over 90*.

Scanned it & turns out it was the egr system.

Like yours, turn engine "off", turn engine "on" & light is gone.

I would think you should have a dtc set?
 

·
Registered
Joined
·
92 Posts
Discussion Starter #4
when i scan the car the only code that appears is 12 which the book says (forget the exact wording) diagnostics functioning properly. thats what has me confused cause you would think the car would store the code?
 
1 - 4 of 4 Posts
Top