Corvette Forum : DigitalCorvettes.com Corvette Forums banner

1 - 14 of 14 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hello,

I am new to your forum. I have an 02 6speed coupe. I took the car to the track and could only muster a 13.55 @107.2. I am a little disapointed. I was hoping for 13'0s. I realize I will have to work on my launch technique. Can anyone give me a performance recipe that will get me into the 12's. The car is new and I do not want to void the warranty. I also do not want to change cam and heads.

Thanks:)
 

·
DC Crew
Joined
·
53,209 Posts
Hi Dave, welcome to the forum! Could you provide the rest of your timeslip data?

That'll help us figure this out. :)
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
my 60FT= 2.10
can't remember the 330ft or 1/8 mile
What 's really crazy is from a 20 roll my coupe will beat my buddy's02 z06 up to 85mph than he goes by me and he runs 12.60's in his car. Thanks
 

·
Registered
Black 08, A&A TI supercharger. Kooks headers. CCW wheels. Much more
Joined
·
12,667 Posts
hey Dave,
the first time i took my c5 to the track,i did my old style launch.rpms at 1200,foot on brake(automatic) second yellow bam im gone get my time slip 14.0 @ 101.there is to much power for the street tires.
now i pull up to line and sit,when both cars are staged i push the pedal just enough to load the powertrain.second yellow,i go,baby the throttle until about 15 ft past the tree,tires still spinning slowly but steadilly floor it.thats alot of wasted power my friend.i now run 13.4 @ 105,please realize our track is .3 slower than mainland due to the coral reef under the track(weeps moisture)and the humidity here can be nasty.sometimes in the 90% range at 10:00 at night.there is no correction factor for humidity,or im sure it would say i run 13.1.the c5 takes alot of practice launching,thats why inexperienced drivers get beat on the street by lesser cars.i might have to get drag radials as to much power is lost babying the thing.like you said too,on the freeway its a different story,no more traction issues,oh,turn off traction control,you need a little spin to keep the rpms up.i dont think you will get 12.6 though,maybe 12.8 or 12.9.good luck,Todd.
 

·
DC PIT CREW BOSS
Joined
·
36,416 Posts
Best of 3 passes, bone stock 13.38 @ 105.7 A4, TC off
 

·
Registered
Joined
·
5 Posts
Discussion Starter #8
what the heck,

Do I have a stone pig vette or what. All you guys run quicker ets please tell me what I am doing wrong.
thanks
Dave P
 

·
DC PIT CREW BOSS
Joined
·
36,416 Posts
dave p, How many miles do you have on it? Is it your only transportation? Will you "just die" if the engine blows up? Mine's out of warranty and I drive it like I stole it. Don't get me wrong, I don't abuse it but I'll push it to the limit. That can make a difference of .2-.3 in the 1/4
 

·
Registered
Joined
·
5 Posts
Discussion Starter #11
When I took the car to the track it had exactly 400 miles on it. I shift the car a 5800 and never left off the gas when I shift. Don't get me wrong from a 20mph roll look out. My coupe will beat my buddy's Z06 from 20-80mph, but at 80 he goes by me. I just can't understand why the car will not et. Are you guys using different tires cause if still use the run flats? When I took the car to the track it consistly ran 107.2-108.1 mph.
 

·
El Teafive
Joined
·
10,489 Posts
dave p said:
my 60FT= 2.10
can't remember the 330ft or 1/8 mile
What 's really crazy is from a 20 roll my coupe will beat my buddy's02 z06 up to 85mph than he goes by me and he runs 12.60's in his car. Thanks
Get that 60ft time down!!

I have a C4 but here is an example.. Same Car, Same Day, no changes, The 60ft makes a big difference

Run #A
60'..........2.340
330.........5.866
1/8..........8.705
MPH........88.35
1000.......11.141
1/4..........13.195
MPH........109.21

Run #B
60'..........2.013
330.........5.435
1/8..........8.246
MPH........89.64
1000.......10.653
1/4..........12.688
MPH........110.81
 

·
Registered
Joined
·
3 Posts
What is the elevation?
Was it humid outside?
Both of those will kill my et. I ran 13.01 at 110.7 on a dry cool day at 700ft, then did 13.44 at 107.5 on a hot humid day with the same 60'

Your 60' is okay with runflats, but you'll need a 1.9 or 2.0 to break 13.

Also, run your car as close to redline as possible before shifting, it will help.
 
1 - 14 of 14 Posts
Top