Corvette Forum : DigitalCorvettes.com Corvette Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Glad I finally found a place to get some answers, because I have a lot of questions. Currently own a Pewter '99 coupe, it' my 3rd. My first one was a brand new 1975 Burgandy T-top, traded that for a '91 black convertable that I traded for the '99. My '99 is starting to have a lot of codes lately, probably time for a new one. Three week ago it started dying at stop lights, engine would drop below 500 RPM, seemed to be searching for the proper idle. I found a vacuum leak at the PCV valve. Replaced valve and hose, idle returned to normal. Next day I backed out of the garage, shifted to drive (automatic), felt a lurch and heard a clunk , neither very severe but definately different. Now it seems like whenever it shifts as low gear (R,F,& S), it is not smooth. Its seems to get smoother after I get a couple miles on it. As soon as the transmission starts shifting smoothly, if I sit at a light for more than 15 to 15 seconds, the "check engine" light comes on. The two codes that I get are PCM-C0113 & C1111. After I clear those codes, the "check engine" light will turn off and I might not have any more problems all day. Any thoughts?
 

·
Premium Member
Joined
·
7,092 Posts
First of all....Welcome to DC.:cheers:

Second off, you probably won't get many Tech guru's in the Intro section, so start a thread in the C5 section. Then sit back and be amazed by all the knowledge you'll receive. :thumbsup:
 

·
DC Crew
Joined
·
53,226 Posts
Welcome! You should post your vette questions in the forum sections so that the experts see it. They may miss it here in the intro section.

Enjoy the site!:thumbsup:
 

·
Premium Member
Joined
·
6,667 Posts
 

·
Registered
Joined
·
1,051 Posts
Welcome Aboard. Enjoy !!!! :cheers:
 
1 - 8 of 8 Posts
Top