Corvette Forum : DigitalCorvettes.com Corvette Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
56 Posts
Discussion Starter #1
I could really use some help on this one, the other day my 01 got hot & started blowing lots of white smoke out the exaust, so now it's at my mechanics & he tells me that he checked the ports where the plugs go in one at a time & there's no sighns of water coming out & insists that if it were a head gasket there would be, he said there was carbon deposits on the plugs but but that's probably because of booster additives I've been using. is there any other reason it could be blowing white smoke ( lots of condensation& water) also not showing any trouble codes.please help:huh:
 

·
DC Crew
Joined
·
53,221 Posts
I could really use some help on this one, the other day my 01 got hot & started blowing lots of white smoke out the exaust, so now it's at my mechanics & he tells me that he checked the ports where the plugs go in one at a time & there's no sighns of water coming out & insists that if it were a head gasket there would be, he said there was carbon deposits on the plugs but but that's probably because of booster additives I've been using. is there any other reason it could be blowing white smoke ( lots of condensation& water) also not showing any trouble codes.please help:huh:
Your mechanic is retarded. Has he actually worked on a car before?

He could have just checked your oil to see if there is coolant in it, or checked the coolant level for a big clue.

The amount of white smoke you see would seem consistent with coolant. You didn't mention you smelled oil, nor that the car consumes oil.
 

·
DC Crew
Joined
·
53,221 Posts
I guess I'll try the trouble codes for an answer . by the way one would have to be a retard to not look for water in the oil & coolent depleation that of course is the 1st thing I did, I'm looking for possable solutions that are not the obvious that's why this problem is a "mystery" some knowlege here would be greatly appreciated.
Ok, I'll bite. What was the conclusion after you checked the fluids?

I'm not sure where the mystery is, sounds like this needs to be properly troubleshooted.
 

·
Registered
Joined
·
56 Posts
Discussion Starter #5
here's a kicker , we did a leak test & all cylinders held 150 lb's of pressure all night & now there's no white smoke blowing out, how is this possable I know I saw a ton of white (vapor) smoke coming out the exaust & now nothing ? has anyone ever heard of such a thing, could my gas have been sabotaged ? what else could possably cause this to happen ? all thoughts & ideas greatly appreciated.:huh:
 

·
Registered
Joined
·
47 Posts
Did you put in SeaFoam the night before?
 
1 - 6 of 6 Posts
Top