Corvette Forum : DigitalCorvettes.com Corvette Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
i just changed out the bad thermostat with a 180deg one,but its still been getting to 230 on my digital gauge,especially when at idle in town its getting real hot,should the thermostat be kicking in,i heard that is normal operating temp in hot weather,but the hotter it gets the rougher it runs.
 

·
DC Crew
Joined
·
4,823 Posts
You probably need to pull the radiator shroud and clean out all of the debris from there. C4's are like a vacuum cleaner. I also bought a hyertech thermomaster chip from ebay a few years ago for about $50 (it programs the fans to kick on earlier). I rarely see temps over 200 anymore.
 

·
Registered
Joined
·
1,065 Posts
C4's are notorious for running hot. I've had several things go with my cooling system, always at different times
1. Leaky radiator, replaced with OEM but would probably go with a better dual core if I could do it over.
2. Somehow I blew out a coolant hose after the dealer replaced my optispark. Thankfully the optispark was still covered under the previous repair warranty.
3. Waterpump gear stripped out. Car would run cool on the highway but get in traffic and it jumped to 220 real quick. So I replaced the water pump.

The important thing to watch out for is the optispark distributor beneath the water pump. Little leak costs big money with it seeps down into the electrical component.

Good luck.
 

·
Registered
Joined
·
724 Posts
Are your fans kicking on?
 
1 - 4 of 4 Posts
Top