Corvette Forum : DigitalCorvettes.com Corvette Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Hi all. I just bought an 84. Seems to run great so far. The only issue I have is that the dash lights went out. All gauges work, just no lights. So I read there is a ground on the left side of the firewall behind the left valve cover..... ANYWAYS, I my search for it, I found a braided ground cable still bolted next to a condenser BUT the other end was connected to a broken piece of black plastic with foil backing. I have looked an looked but can not see what it came from. It does have what looks like a press clip connector, but no writing or ID marks. The braided cable is about 9 inches long. Is this part of what the dash lights WERE grounded to? Any ideas? Help!
 

·
Registered
Joined
·
68 Posts
Hi all. I just bought an 84. Seems to run great so far. The only issue I have is that the dash lights went out. All gauges work, just no lights. So I read there is a ground on the left side of the firewall behind the left valve cover..... ANYWAYS, I my search for it, I found a braided ground cable still bolted next to a condenser BUT the other end was connected to a broken piece of black plastic with foil backing. I have looked an looked but can not see what it came from. It does have what looks like a press clip connector, but no writing or ID marks. The braided cable is about 9 inches long. Is this part of what the dash lights WERE grounded to? Any ideas? Help!
The black piece with the ground cable and the foil backing is the piece that covers the distributor cap. Most don't have theirs, but I still do on mine.
 

·
Registered
Joined
·
128 Posts
That makes sense given the length of the cable. But out of curiosity, what does it ground?
There was a foil-backed plastic shield that snapped over the top of the distributor, that's where that ground strap went.
It was supposed to reduce RFI noise into the radio and other things, although removing it doesn't seem to harm anything.

The ground for the IP cluster is located towards the rear of the engine, below driver's side rocker cover.
 

·
Registered
Joined
·
414 Posts
Hi all. I just bought an 84. Seems to run great so far. The only issue I have is that the dash lights went out. All gauges work, just no lights. So I read there is a ground on the left side of the firewall behind the left valve cover..... ANYWAYS, I my search for it, I found a braided ground cable still bolted next to a condenser BUT the other end was connected to a broken piece of black plastic with foil backing. I have looked an looked but can not see what it came from. It does have what looks like a press clip connector, but no writing or ID marks. The braided cable is about 9 inches long. Is this part of what the dash lights WERE grounded to? Any ideas? Help!

If i was you, I would go ahead and replace the bulbs behind the lcd screens while your at it, its not that expensive and theylle be brighter.

On the bright side, jsut be glad yours work!! most 84's quit working along time ago!
 
1 - 8 of 8 Posts
Top