Corvette Forum : DigitalCorvettes.com Corvette Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
543 Posts
Discussion Starter #1
How can you tell if your pre cats are bad.

After installing the new motor The pre cats are both smoking.

The Right side cat smoked before the motor swap but now both of them are smoking.

White smoke comming off the outside body of the cats under the heat sheilds.

I tryed to run the motor to burn off what every making them smoke no luck so far.

The smoking starts after the cats get hot it seams like when it get up top temp to light off for smog thats when they start smoking.

Also notice the motor runs a little ruff when they come up to temp.

The water temp is normal and the oil temp is normal.

I tryed to use some engine cleaner on the cats then wash them off but still smoking.

I don't smell like oil or coolent just white smoke.

Any Ideas or are the cats gone bad on me.
 

·
Registered
Joined
·
138 Posts
Also notice the motor runs a little ruff when they come up to temp.

turn it off,let it cool down,then pull the plugs,sounds like anti freeze to me,see if the plugs are foulen. Out of curosity tho,why pre cats on your 86 ? Is that for CA smog ?
 

·
Registered
Joined
·
543 Posts
Discussion Starter #3
Yes the cats are for Ca smog but I am finding out I don't have to have them.

I found why they were smoking I pulled the Exhaust manifolds there was a leak from the valve cover gasket you could not see until you had the exhaust off.

I pulled the pulgs they look good.

I still getting the bugs out the new motor.

Also notice the motor runs a little ruff when they come up to temp.

turn it off,let it cool down,then pull the plugs,sounds like anti freeze to me,see if the plugs are foulen. Out of curosity tho,why pre cats on your 86 ? Is that for CA smog ?
 
1 - 4 of 4 Posts
Top