Corvette Forum : DigitalCorvettes.com Corvette Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I have a 2008 C6 coupe with the NAV system, CD, and Radio combo. Lately the unit display just turns off and on randomly. When in this condition no controls function not even the power switch. The unit goes blank and the Corvette logo comes on and off randomly like on a power on. The radio still functions while doing this and the volume control kinda works. It seems to be a loose connection because I when I am on a rough road and it sometimes comes back on or off. I didn't want to take the console apart unnecessarily. The LCD back light does turn off and on but it will turn on with no display sometimes.

Anybody have any suggestions?:huh:
 

·
Registered
Joined
·
80 Posts
Sounds like a short or a loose ground. I see this post is a bit dated, did you track the problem down?
 

·
Registered
Joined
·
21 Posts
Still under warranty?
Loose fuse?
Any recent upgrades to the electronics, like gauges?
if aftermarket check your wire harness for solid connection.

Interested to see what you find.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
Not under warranty anymore unfortunately. A loose ground or fuse sounds like a possibility. No after market upgrades. All stock. I'll look at the fuse first. The ground will probably mean console removal. I found a post on here on how to do that. Attempted to remove the shifter boot like said but it would not turn easily to unlock it and I didn't want to force it. If the fuse is OK I'll attempt the console removal again. I'm thinking if I can get the radio out that it might just be unplugging it and plugging it back in a few times. One thing I have also noticed is when it is working the contrast is off with strange fading.

Have not found anybody with same problem.

Thanks for the responses.
 
1 - 4 of 4 Posts
Top