Corvette Forum : DigitalCorvettes.com Corvette Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I just got the car back together and I started it up on the jack stands before I took it down and i have a problem. I switched over to a SMFW with a Centerforce Dual Friction clutch. Also while i was in there put in new AC Delco Master and Slave cylinders. A real quick background, I got the SMFW machined down and after it was done the machine shop told me that it was .020 thinner from the crank face to the clutch face than the DMFW. They advised a flywheel spacer, so I went and bought a .025 shim to put in between the crank and flywheel to solve that issue. (Dont know why if they took off .090 it would be .020 shorter than the DMFW, it was a new FW) NOW, the problem i have is when i start it up and push in the clutch and it gets towards the bottom of floor it will make a ting ting ting like something is hitting and the damn thing doesnt go into gear to easy. WTF did i do wrong??? I am in dire need of some help guys please!!
 

·
El Teafive
Joined
·
10,489 Posts
Which SMFW did you install? Why did you have .090 shaved?

I am guessing if it was shaved as suggested and re assembled without the spacer it might work.

Also do you know for certain that the clutch hydraulics are working 100%, with our clutches even BRAND NEW parts can be bad..

I when through 7 masters (all leaked) within a 3 month period
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
Its a SM from an F-body that needs .090 shaved in order to work. (per forum members and websites) I havent had any problem with the hydraulics yet. (no leaks) You've had problems with the AC Delco ones being bad? I posted on another forum as well and one suggested that the fork is hitting the PP, which sounds right if I put the spacer in and it has put the flywheel to far forward. So i guess I'll tear it apart and see what looks like was hitting and figure out what to do. Man this sux!!!!
 

·
El Teafive
Joined
·
10,489 Posts
Its a SM from an F-body that needs .090 shaved in order to work. (per forum members and websites) I havent had any problem with the hydraulics yet. (no leaks) You've had problems with the AC Delco ones being bad? I posted on another forum as well and one suggested that the fork is hitting the PP, which sounds right if I put the spacer in and it has put the flywheel to far forward. So i guess I'll tear it apart and see what looks like was hitting and figure out what to do. Man this sux!!!!
Yeah is sounds like the fork is hitting the PP
 
1 - 4 of 4 Posts
Top