Corvette Forum : DigitalCorvettes.com Corvette Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
5,968 Posts
Discussion Starter #1
Hey gang:buhbye:. I was cleaning the back window in the coupe today, and noticed this. Can anyone help?



Thanks in advance. Hope everyone has a great weekend:cheers:
 

·
Registered
Joined
·
5,968 Posts
Discussion Starter #2
Sorry about the lousy pic, and the messy garage...:laughing:
 

·
Registered
Joined
·
5,968 Posts
Discussion Starter #4
Rear window defroster? thats what it looks like to me
That much I figured I figured out myself, thanks. Im looking for a way to repair it without ANY chance of cracking the glass.
 

·
Registered
Joined
·
5,968 Posts
Discussion Starter #6

·
Registered
Joined
·
5,968 Posts
Discussion Starter #8

·
Registered
Joined
·
175 Posts
It looks like you need to resolder the wire back on.

I've had to do this on a few different cars.
The trick is to have a somewhat larger soldering iron.
I think the one I use is around 25 watts or so.

You need one hot enough to heat the terminal and wire quickly without getting all the heat drawn out of it.

I bet if you took your car to a stereo shop, they could reattach it in about 5 minutes.
 

·
Registered
Joined
·
5,968 Posts
Discussion Starter #10
Thank You :cheers:
 

·
Registered
Joined
·
5,968 Posts
Discussion Starter #12
:laughing:. I'm trying AJ. Had a flat yesterday. No-one wants to repair it. When it rains it pours I'm guessin:smack. I think I'll drive the truck for a few. It's a lot cheaper to repair:thumbsup:
 
1 - 12 of 12 Posts
Top