Corvette Forum : DigitalCorvettes.com Corvette Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
606 Posts
Discussion Starter #1
Been having high temp problems. Flushed the radiator real good without the thermostat. Refilled rad with a 50/50 mix and left the stat out. Drove around about 20 minutes and it didn't get over about 175. Is it OK to run w/o a stat in the summer?

Thanks!
 

·
Banned
Joined
·
3,855 Posts
IMO, I have to run without a stat all summer, have not found one yet that lasted longer than 2 years.....TT here had recommended a Volvo stat, but in fact it's not better for MY useage anway....

over the years I have found thermostats are all over the map in performance, opening temps, closing temps, flow rates, etc....

and totally unreliable....since here in Florida I tend to say hell with them....but up north I allways ran one in winter....
 

·
Banned
Joined
·
3,855 Posts
You can also try running the restrictors. Jegs sells them.
I don't have to bother NOW, I finally got rid of some glommy looking hookup I never liked for the upper hose, due to air induction I used to have...and went over to a more normal looking upper hose for a TPI setup, and the housing has about 1" diameter for flow, same as a 'restrictor plate' or slightly larger than a 195F stat....

another thing I have noticed over the years....180f stats are rarely that...they open at 195f....and the new ones have smaller openings...have to go to a 160f stat to get the older wider opening, allowing more flow...

once again the EPA to our rescue, I suspect....
 

·
Registered
Joined
·
2,366 Posts
I'm not sure if I have one right now. I'm changing my lower radiator hose soon so I should check. I also plan on doing some welding after taking the radiator out. :devil:
 
1 - 6 of 6 Posts
Top