Corvette Forum : DigitalCorvettes.com Corvette Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
302 Posts
Discussion Starter #1
First off, what does it mean?
I turn my key and everything lights up, but SYS is blinking at me.

The car takes a long time to start.
Idles extremely high.
The speedometer doesn't work.
and if I push to gas too hard, the car does somthing similar to when you hit the rev limiter.

There may be other things but this is all I can notice.

If anyone can provide some insight into what I may be dealing with, any and all help is appreciated.

I'm going to go disconect my battery and re connect it to see if it helps, but i really want to be rid of this forever.

UPDATE* unhooking the battery for a minute worked, but i still really don't like the idea that this can just come back at any time.

Thanks
 

·
Registered
Joined
·
302 Posts
Discussion Starter #3
As far as codes go, this is a list I have from a couple months ago...

Code #25: Intake Temperature Sensor Circuit High.
Code #26: Quad-Driver Module #1 Circuit.
Code #27: Quad-Driver Module #2 Circuit.
Code #28: Quad-Driver Module #3 Circuit.
Code #33: Manifold Absolute Pressure Sensor Circuit Low.
Code #34: Manifold Absolute Pressure Sensor Circuit High.
Code #36: Opti-Spark Ignition Timing System. (High Resolution Pulse.)
Code #41: Electronic Spark Timing Circuit Open.
Code #42: Electronic Spark Timing Circuit Grounded.
Code #43: Electronic Spark Control Circuit.
Code #45: Left Oxygen Sensor Circuit Rich.
Code #51: Mem-Cal Error.

I'll see if I can get an updated list in the next couple days, but I guess, for now this is somthing to work with.
I barely understand what this stuff means so if someone can point me in the right direction by these codes, I'd really appreciate it.

Thanks
 

·
Registered
Joined
·
83 Posts
I have read where a drained or low battery could cause the SYS light to come on. I have not had this problem with my car, but it might give you peace of mind to check it anyway.
 

·
Premium Member
Joined
·
7,092 Posts
Kevin.....All those codes you retrieved from your vette give you an area to look at for the problem(s). I know even with the codes it's difficult to narrow a specific problem down at times. I had a code my '99 Z71 gave and tried replacing a few parts.....none worked. I just so happened to be at the Chevy dealer getting a part for my vette and asked the parts guy for some advice. He then asked the technician about the code, told me what to look for, and I was able to find the faulty part (egr valve). You might want to ask a Chevy dealer if they'll be willing to give you advice if you're having a problem narrowing down a particular problem. You just might get lucky and they'll answer it.

You should think about investing in a Factory Service Manual though.
 

·
Premium Member
Joined
·
5,157 Posts
You should think about investing in a Factory Service Manual though.
Yeah - without the FSM you're really just whistlilng in the dark. The codes you've quoted cover a wide variety of things, and the original problem could range from a simple ground issue somewhere (all the HIGH & LOW signal problems) to a problem in the ECM.

The FSM will provide specific troubleshooting steps for all these things, and will help you narrow down the problem.

Trust me, you really don't want to just start randomly replacing parts. That will be nothing more than your own version of "Highway to Hell"!!!

Steven
 

·
Registered
Joined
·
302 Posts
Discussion Starter #7
Thanks for all responses.
It's not the battery, unfortunately.
I guess it is time for a service manual... I was hoping to not have to get one because they are kinda pricey, but it is pretty clear that it is a good investment.

Thanks all
 

·
Registered
Black 08, A&A TI supercharger. Kooks headers. CCW wheels. Much more
Joined
·
12,668 Posts
sorry to say,but it looks like the opti spark is shot,did you spray the front of the motor with water lately?
 

·
Registered
Joined
·
302 Posts
Discussion Starter #10
I really hope it's not the opti spark, I haven't put any water anywhere under the hood, but I suppose that doesn't mean that none ever has.
MR-corvette - I'll check that thread, thanks
 
1 - 10 of 10 Posts
Top